Symbols

 Symbol, explanation:

, generalized skew coefficient.
, historically-adjusted skew coefficient.
', skew coefficient of frequency curve passing through [image], [image], and [image].
|G|, absolute value of the station skew coefficient.
G, station skew coefficient.
GW, Bulletin 17B skew coefficient estimate used in final log-Pearson Type III frequency curve.
g, desired skew coefficient.
H, historical period length.
K, confidence coefficient.
KN, 10 percent significance level outlier tests KN values for a normal distribution for sample size N.
kg, p, Pearson Type III standardized ordinates for desired skew (g) and exceedance probability (p).
kp, standard normal frequency factor for probability p.
kp', frequency factor after adjustment with Student-t.
, historically-weighted logarithmic mean.
, Bulletin 17B mean.
, mean of frequency curve passing through [image], [image], and [image].
, historically-weighted rank of the m-th largest observed peak.
m, rank of the m-th largest observed peak.
MSE, mean-square error (standard error of estimate squared).
MSE [image] , mean-square error of generalized skew coefficient.
MSEG, mean-square error of station skew coefficient.
, effective number of peaks above flood base, QO.
NBB, number of peaks below the flood base, including any zeros and low outliers.
NHO, number of high outliers.
NHP, number of historic peaks.
NS, number of systematic peaks.
NX, number of peaks betweenQO and QH.
n, sample size from normal population of flood logarithms.
, probability plotting position of the m-th ranked observed peak.
, estimated probability of exceeding the flood base.
p, exceedance probability.
p', normal exceedance probability corresponding to kp'.
, conditional frequency curve describing only those peaks above a base.
, intermediate unconditional frequency curve.
, final Bulletin 17B-estimated frequency curve.
QH, historical threshold streamflow.
QO, flood base streamflow.
, systematic frequency curve.
S, sample logarithmic standard deviation.
, Bulletin 17B standard deviation.
, historically-weighted logarithmic standard deviation.
, standard deviation of frequency curve passing through [image], [image], and [image].
tn - 1, p, student's t with n-1 degrees of freedom and exceedance probability p.
W, weight given to systematic peaks.
X', logarithmic magnitudes of historic peaks and high outliers.
, sample logarithmic mean.
X, logarithmic magnitudes of systematic peaks between QO and QH.
, confidence limit.
, population skew coefficient.
, population mean.
, population standard deviation

Note: All symbols and explanations from Interagency Advisory Committee on Water Data (1982) and Lepkin and others (1979).


Abstract

 Estimates of flood flows having given recurrence intervals or probabilities of exceedance are needed for design of hydraulic structures and floodplain management. Program PeakFQ provides estimates of instantaneous annual-maximum peak flows having recurrence intervals of 2, 5, 10, 25, 50, 100, 200, and 500 years (annual-exceedance probabilities of 0.50, 0.20, 0.10, 0.04, 0.02, 0.01, 0.005, and 0.002, respectively). As implemented in program PeakFQ, the Pearson Type III frequency distribution is fit to the logarithms of instantaneous annual peak flows following Bulletin 17B guidelines of the Interagency Advisory Committee on Water Data. The parameters of the Pearson Type III frequency curve are estimated by the logarithmic sample moments (mean, standard deviation, and coefficient of skewness), with adjustments for low outliers, high outliers, historic peaks, and generalized skew. This documentation provides an overview of the computational procedures in program PeakFQ, provides a description of the program menus, and provides an example of the output from the program.


Introduction

 Program PeakFQ performs statistical flood-frequency analyses of annual-maximum peak flows (annual peaks) following procedures recommended in Bulletin 17B of the Interagency Advisory Committee on Water Data (1982), referred to hereinafter as Bulletin 17B. The following sections document the implementation of the Bulletin 17B guidelines in program PeakFQ. This information is intended to assist the user with selection of program options and interpretation of the program output. Program users should refer to Bulletin 17B itself for the complete and definitive description of the recommended procedures.

The Bulletin 17B procedures treat the occurrence of flooding at a site as a sequence of annual random events or trials. The magnitudes of the annual events are assumed to be independent random variables following a log-Pearson Type III probability distribution; that is, the logarithms of the annual peak flows are assumed to follow a Pearson Type III distribution. This distribution defines the probability that any single annual peak will exceed a specified streamflow. Given this annual exceedance probability, other probabilities, such as the probability that a future design period will be free of exceedances, can be calculated by standard methods, as described in Appendix 10 of Bulletin 17B. Program PeakFQ estimates the parameters of the log-Pearson Type III frequency distribution from the logarithmic sample moments (mean, standard deviation, and coefficient of skewness) of the record of annual peak flows, with adjustments for low outliers, high outliers, historic peaks, and generalized skew. The parameter values are used to calculate the percentage points (or quantiles) of the log-Pearson Type III distribution for selected exceedance probabilities.


Peak Streamflow Records

 The U.S. Geological Survey maintains a peak-flow file in the National Water Information System (NWIS) data base. The contents and format of data retrieved from the peak-flow file are described in Appendices B.2 (Station Header Records) and B.4 (Peak-Flows Records). Program PeakFQ uses the station identification number and name to label the printed output and may use the station latitude and longitude to look up the generalized skew. The Bulletin 17B statistical computations use only the annual-peak discharge and discharge-qualification codes on the type 3 records; the gage-height information and all information about partial-duration or secondary peaks (type 4 records) are ignored.

The annual-peak-flow data fall into two classes: systematic and historic. The systematic record includes all annual peaks observed in the course of one or more systematic gaging programs at the site. In a systematic gaging program, the annual peak is observed (or estimated) for each year of the program. Several systematic records at one site can be combined, provided that the hydrologic conditions during the periods of record are comparable. The gaps between distinct systematic-record periods can be ignored, provided that the lack of record in the interim was unrelated to the hydrologic conditions. Thus, if a flood record was interrupted for lack of funds for data collection, the interruption could be ignored and the available data could be used as if no interruption had occurred. On the other hand, if the record was interrupted because of prolonged drought or excessive flooding, the interruption should not be ignored but rather should be used, if possible, as evidence for adding one or more estimated peaks to the systematic record. Thus, the systematic record is intended to constitute an unbiased and representative sample of the population of all possible annual peaks at the site.

In addition to the systematic record, some stations have a historic record consisting of generally isolated high-magnitude peaks that occurred outside the period of systematic data collection. In contrast to the systematic record, the historic record consists of annual peaks that would not have been observed except for a recognition that an unusually large peak had occurred. . Flood information acquired from old newspaper articles, letters, personal recollections, and other historical sources almost invariably refers to floods of noteworthy, and hence extraordinary, size. Similarly, paleoflood information, determined by analysis of geological or botanical evidence, is considered historic information and almost always refers to extraordinary floods. Thus, historic records, by the conditions of their collection, form a biased and unrepresentative sample of flood experience. Despite this bias, however, the historic record can be used to supplement the systematic record provided that all historic peaks above some historic threshold have been recorded.

The systematic record also may contain one or more large-magnitude peaks for which historic information is available or which exceed some historic peaks. Such peaks are called high outliers. They are not considered historic peaks because they are part of the systematic record. In particular, the peak of record is not considered a historic peak if it occurred during a period of systematic data collection. Although high outliers are part of the systematic record they also are treated in the same way as historic peaks in the historic-record adjustment procedure.

Qualification codes are assigned to some peaks, in order to identify (1) basin or environmental conditions that may have affected the magnitude of the streamflow, (2) measurement conditions that may have affected the accuracy of the recorded value and (3) historic peaks. These codes are described in Appendix B.4 and also in the NWIS-Web Help System at URL -- http://nwis.waterdata.usgs.gov/nwis/help?codes_help#flow_qual_cd. Note that an individual peak flow can have more than one qualification code associated with it. Program PeakFQ recognizes several of these codes and uses them to control the statistical computation. For example, discharge code 4 (discharge less-than indicated value, reported as the mnemonic letter code L in the PeakFQ output file) automatically triggers the zero-flow and conditional-probability adjustments. Table 1 identifies the peak-flow-file qualification codes used by program PeakFQ, explains how these codes are interpreted by the program, and briefly describes how the PeakFQ program handles the associated peaks.

Table 1. Peak-flow codes used by program PEAKFQ
PeakFQ code | NWIS code | PeakFQ Interpretation | PeakFQ Action
D | 3 | Dam failure, non-recurrent flow anomaly | Always excluded.
G | 8 | Discharge greater than stated value | Always excluded.
X | 3 and 8 | Both D and G | Always excluded.
L | 4 | Discharge less than stated value | Conditional-probability adjustment.
K | 6 or C | Known effect of regulation, urbanization, or other watershed change | Excluded by default. Can be included by specifying "yes" in the "Urban/Reg Peaks" field of the PEAKFQ station specifications.
H | 7 | Historic peak. (Note: Historic peaks are events that occur outside periods of systematic data collection. The peak of record is not a historic peak if it was observed as part of the systematic record collection. See text for additional details.) | Excluded by default. Can be included by specifying a value for historic period in the PeakFQ station specifications, in which case the historic adjustment will be applied.
- | 1, 2, 5, 9, A, B, or E | Codes are not considered by PeakFQ | Always included.
The NWIS peak-flow codes are described in Appendix B.4 and also in the NWIS-Web Help System at http://nwis.waterdata.usgs.gov/nwis/help?codes_help#flow_qual_cd


Principles of Computation

 The Bulletin 17B computational analysis is illustrated in figure 1. The following sections provide an overview of the major computational steps.


Systematic-Record Analysis

 The systematic-record analysis involves the computation of the mean, standard deviation and coefficient of skewness ( [image], S, and G, respectively) of the common logarithms of the annual peak flows in the systematic record. At some sites, annual peaks of magnitude zero can occur; more generally, the annual peak may occasionally fall below or be equal to some lower limit of measurement called the gage base (which usually is zero but may be greater than zero). To account for this possibility, the number of peaks below the gage base is computed in addition to the mean, standard deviation, and skewness of the logarithms of the above-base systematic peaks. The statistics of the above-base systematic peaks and the number of peaks below the gage base are used to compute the systematic-record frequency curve. If there are no zeroes or below-base peaks, the systematic-record frequency curve is computed as follows:

(1)

where | = | systematic frequency curve ordinate at exceedance probability p, and
kG,p | = | the Pearson Type III standardized ordinates for station skew G and exceedance probability p.

If there are zeroes or below-base peaks, the statistics of the above-base systematic peaks are used to define a conditional above-base systematic-record frequency curve which is then adjusted by the conditional-probability adjustment, as described in a subsequent section and in Bulletin 17B, Appendix 5.

The systematic-record frequency curve is an initial estimate of the Bulletin 17B frequency curve. This initial estimate is adjusted to account for historic data, high and low outliers, and regional (generalized) skew information.


Outlier Tests

 The first adjustments of the initial frequency curve involve detecting and accounting for high and low outliers. The sequence of these tests and adjustments depends on the station skew coefficient, G, computed in the first step. Because a relatively large skew coefficient of either sign (G > 0.4 or G < -0.4) is likely to be caused by an outlier on the corresponding end of the sample, this possibility is checked first and any necessary adjustment is applied before checking for outliers on the other end. If the skew coefficient is of moderate size (-0.4 < G < 0.4), the existence of both high and low outliers can be checked before applying any adjustments.

Program PeakFQ tests for high outliers using the following equation:

(2)

where XH | = | Logarithmic high-outlier test threshold, and
KN | = | 10-percent significance-level critical value for outlier test statistic for samples of size N from the normal distribution. (See Bulletin 17 B Appendix 4.)

Program PeakFQ does not automatically use the high-outlier test threshold in the analysis. The program requires the user to specify the high-outlier threshold and length of historic period in order for the high-outlier and historic-peak adjustment to be applied. The computations for performing the adjustment are described in the next section.

Program PeakFQ tests for low outliers using the following equation:

(3)

where XL =logarithmic low-outlier test threshold.

If an adjustment for historic data has previously been made, then the following equation is used to detect low outliers:

(4)

where | = | historically-weighted logarithmic mean, and
KH | = | 10 percent significance-level critical value for outlier test statistic for sample of size H, where H is the length of the historic record period.
 | = | historically-weighted logarithmic standard deviation.

The computation of [image] and [image] is described in the next section.

The frequency curve is automatically adjusted for the effect of low outliers using the conditional probability adjustment described later.


Historic-Record Adjustment

 Recalculation of the statistics of the above-base peaks is required after the detection of outliers or historic information, as specified in Appendix 6 of Bulletin 17B. The logical basis for the calculation is the following:

Historic adjustment criterion: Every annual peak that exceeded some historic threshold streamflow (QH) during the historic period (H) has been recorded as either a historic peak or a systematic peak (high outlier). In other words, the record is complete for peaks above QH during the time period H.

The historic period H includes the systematic-record period plus one or more years that have no systematic record. This criterion implies that the unrecorded portion of the historic period contains only peaks below the threshold QH. Figure 2 presents a definition sketch showing the time periods and streamflows used in the historic-record adjustment.

The Bulletin 17B historic adjustment, in effect, fills in the ungaged portion of the historic period with an appropriate number of replications of the below-QH portion of the systematic record. The adjustment is accomplished by weighting the below-threshold systematic peaks in proportion to the number of the below-threshold years in the historic period, as illustrated in figure 2, as follows:

(5)

where W is the weight to be applied to the below-threshold systematic peaks and NS, NHP, and NHO are the numbers of systematic peaks, historic peaks, and high outliers, respectively. Then the effective number of peaks, [image], above the flood base (QO) is

(6)

where NBB is the number of peaks below the flood base, including any zeros and low outliers.

The corresponding estimated probability of a flood exceeding the flood base is

(7)

Applying the historic weight W to those systematic peaks below the historic threshold QH (and above the flood base QO) yields the following formulas for the historically-weighted mean ( [image]), standard deviation ( [image]), and skewness ( [image]):

(8)

(9)

(10)

in which X´ denotes logarithmic magnitudes of historic peaks and high outliers and X denotes logarithmic magnitudes of systematic peaks between the flood base QO and the historic threshold QH. These formulas are equivalent to those given in Appendix 6 of Bulletin 17B.

These formulas remain correct even if there is no historic information (in which case H = NS), no high or low outliers, and no below-gage-base peaks. Thus these formulas are used in PeakFQ to calculate the Bulletin 17B statistics in all cases, including the calculation of the unadjusted systematic-record statistics.


Conditional-Probability Adjustment

 After the peak-streamflow frequency curve parameters have been determined, the historically-weighted frequency curve can be tabulated. If no low outliers, zero flows, or below-gage-base peaks are present, this process is simply a matter of looking up the Pearson Type III standardized ordinates, kg, p for the desired skew coefficient (g) and probability (p) and computing the logarithmic frequency curve ordinates by the formula:

(11)

When peaks below the flood base are present, however, the above calculation determines a conditional frequency curve [image] describing only those peaks above the base. To account for the fraction of the population below the flood base, the following argument is used: the probability that an annual peak will exceed a streamflow x (above the flood base) is the product of the probability that the peak will exceed the base at all, times the conditional probability that it will exceed x, given that it exceeds the base. The first of these factors is just the probability [image] calculated in equation (7); the second factor is the probability on the conditional-frequency curve at streamflow x. Thus the unconditional curve, [image], assigns a probability [ [image]]p to the streamflow having exceedance probability p on the above-base curve. Conversely, an exceedance probability p on the unconditional curve [image] corresponds to the probability p/ [image] on the original above-base curve [image]. Thus the ordinates of the unconditional curve can be computed directly by the formula:

(12)

In which [image], [image], and [image] are the logarithmic mean, standard deviation and skew coefficient of the above-base distribution.

Because this distribution does not have the Pearson Type III shape, it is used only as an intermediate step in constructing an equivalent Pearson Type III curve. First, the three points [image], [image] and [image] are computed using the above formula. Then a logarithmic Pearson Type III curve is passed through these three points; its mean, standard deviation, and skew coefficient, [image], [image], and [image] ', are found by solving the three simultaneous equations:

(13)

An exact solution requires a laborious interpolation in the Pearson Type III tables; the Bulletin 17B guidelines present a direct formula based on a linear approximation. Note that [image], [image], and [image] ' represent the contributions of all the observed peaks, those below the base as well as those above, whereas [image], [image], and [image] did not. The resulting unconditional-frequency curve, when floods below the base have been detected, then is:

(14)

This defines only the part of the distribution above the flood base; the part below the flood base is not defined, but is of no practical importance.

These conditional-probability adjustments are used not only to construct the final Bulletin 17B frequency curve but also to construct a systematic-record frequency curve that takes into account any zero flows or below-gage-base peaks (but not low outliers).


Computation of Weighted Skew Coefficient

 The station- (or sample-) skew coefficient, which reflects the average of the cubed deviations from the sample mean, is highly sensitive to the observations in both the upper and lower tails of the sample. As a result, the estimated station-skew coefficient and extreme-flood quantiles may be strongly affected by idiosyncrasies of the sample, and may be unrepresentative of long-term flood characteristics. To help counter this problem, Bulletin 17B uses a generalized skew, which is a skew coefficient representative of neighboring stations, as explained in a subsequent section.

The station skew and generalized skew are combined in a weighted average that is expected to be more accurate than either of its constituents. Guidelines for estimating generalized skew are given in Bulletin 17B and are summarized in a subsequent section of this manual. Program PeakFQ does not perform generalized skew estimation. Instead, program PeakFQ either looks up the generalized skew from a digitized copy of the map in Bulletin 17B or reads it from user-supplied input (see preceding section). The following paragraphs explain the weighted skew computation.

The station skew, the generalized skew, and the weighted skew all are quantities that are estimated from flood records at and near the station under study. As such, they are subject to estimation errors. The error in each of the skew statistics is characterized by two properties, the expected value (bias) and the standard deviation (standard error), representing systematic errors and random-sampling variability, respectively. The random and systematic errors are combined in a single composite property called mean square error (MSE), which is the expected value of the difference between the estimated and true values of the statistic (station, generalized, or weighted skew). The MSE is the sum of the squares of the bias and standard error. The MSE often is reported in terms of its square root, the Root Mean Square Error (RMSE), which is directly comparable to the quantity being estimated (rather than to its square) and can be expressed as a percentage. If the bias is small relative to the standard error, the RMSE is approximately equal to the standard error. Because of its wide availability and usefulness, the RMSE is used as input to program PeakFQ; the program squares the input RMSE to obtain the MSE values used in equation 15.

The station- and generalized-skew coefficients are combined in a weighted average to form a better estimate of the skew coefficient for a given watershed. Under the assumption that the generalized-skew coefficient is unbiased and independent of the station-skew coefficient, the MSE of the weighted-skew estimate is minimized by weighting the station- and generalized- skew coefficients in inverse proportion to their individual MSE's. This concept is expressed in equation 15, adapted from Tasker (1978), which is used in computing the weighted-skew coefficient:

(15)

where GW | = | weighted-skew coefficient,
G | = | station-skew coefficient,
 | = | generalized-skew coefficient,
MSE | = | mean-square error of generalized-skew coefficient, and
MSEG | = | mean-square error of station-skew coefficient.

The MSE (or RMSE) of the generalized skew is estimated in conjunction with the development of the generalized-skew value. In program PeakFQ, if the user does not specify a value for the generalized-skew coefficient, the value is obtained from a digitized version of Plate 1 of Bulletin 17B, and the corresponding value of MSE [image] = 0.302 is used in equation 15. (The corresponding RMSE value is 0.55.) Otherwise, the user must supply the RMSE of the generalized skew as input data along with the user-supplied generalized-skew value.

The MSE of the station skew for log-Pearson Type III random variables is obtained from the results of Monte Carlo experiments by Wallis and others (1974). Their results show that the MSE of the logarithmic station skew is a function of record length and population skew. This function (MSEG) is approximated with sufficient accuracy for use in calculating the weighted skew by the equation:

(16)

where

in which |G| is the absolute value of the station-skew coefficient (used as an estimate of population-skew coefficient) and N is the record length in years. If the historic adjustment (Bulletin 17B, Appendix 6) has been applied, the historically-adjusted skew coefficient, [image], and historic period, H, are used for G and N, respectively, in equation 16.

Bulletin 17B indicates that equations 15 and 16 may underestimate the weight given to the station skew if it is large and the record is long, or if its magnitude differs from the generalized skew by more than 0.5. In these cases Bulletin 17B suggests that the peak-flow data and the flood-producing characteristics of the basin be examined to determine whether greater weight should be given to the station skew.


Expected-Probability Adjustment

 The final steps in the Bulletin 17B analysis, as implemented in program PeakFQ, are to compute the expected-probability frequency curve and a set of upper and lower confidence limits. These computations are optional and are intended primarily as an aid to the interpretation of the principal Bulletin 17B-estimated frequency curve given by [image] p above.

The expected probability concept deals with the following problem. A sample of size n will be drawn from a normal population (of flood logarithms), and the flood having a specified exceedance probability p will be estimated by the quantity [image] + kpS, in which [image] and S are the ordinary sample mean and standard deviation and kp is the standard normal frequency factor for probability p. Because it is computed from a random sample, the estimate [image] + kps is a random variable, which usually will differ from the true p-probability flood. Thus one is led to ask how the probability of another flood exceeding the estimate [image] + kpS compares with the specified (nominal) probability p. For a normal population one has:

(17)

where tn-1 is Student's t random variate with n-1 degrees of freedom. This probability has come to be known as the "expected probability" (Beard, 1960; Bulletin 17B, Appendix 11). For nominal exceedance probabilities less than 0.50 (floods above the median) the expected probability exceeds the nominal probability. The expected probability can be made equal to the nominal probability by replacing kp by the frequency factor:

(18)

in which tn-1,p is the Student's t value with n-1 degrees of freedom and exceedance probability p. The visible effect of this adjustment is to increase the slope of the estimated frequency curve in proportion to the statistical variability of the sample statistics.

This normal-population result is applied to the Bulletin 17B-estimated Pearson Type III distribution with mean, standard deviation, and skew coefficient, [image], [image], and GW, by first looking up the normal exceedance probability p' corresponding to k'p and, second, applying the Pearson Type III frequency factor, kG, p' having skew coefficient and probability, to the sample mean and standard deviation, as follows: + [image] (kGW, p'). Of course, even this estimate, when evaluated for any particular sample, normally will misrepresent the true p-probability flood. With respect to a large number of flood records, however, the fraction of floods actually exceeding the estimated p-probability floods will be correct. Nonetheless, the Bulletin 17B guidelines specify that the basic flood-frequency curve (without expected probability) is the curve to be used for estimating flood risk and forming weighted averages of independent flood-frequency estimates.


Confidence Limits

 Finally, one-sided confidence limits for the p-probability flood are computed. A one-sided confidence limit is a sample statistic-hence a random variable-having a specified probability (confidence level) of exceeding (or not exceeding) a specified population characteristic. In the Bulletin 17B analysis, these statistics are of the form [image] + KS, where [image] and S are the sample mean and standard deviation after all Bulletin 17B tests and adjustments and K is a confidence coefficient chosen to satisfy the following equation:

(19)

In which [image] is the confidence limit, [image], [image], and [image] are the population mean, standard deviation, and skew coefficient, K [image] p is the Pearson Type III frequency factor, and the right-hand side of the inequality is the population p-probability flood. The population parameters are unknown, but constant. The idea is to find a K-value such that [image] + K S, which can be computed from the sample, and is a random variable, will have a high probability of being an upper (or lower) bound on the unknown population p-probability flood. In any particular sample the computed value [image] + K S may fail to bound the population characteristic, but, over a number of samples, the specified fraction- [image] (or 1- [image])-will yield correct bounds. A value of [image] close to unity yields upper confidence limits and a value close to zero yields lower limits. In particular, the upper 95-percent confidence limit has [image] = 0.95; the lower 95-percent limit has [image] = 0.05. The value of K is found by rearranging the probability statement as follows:

(20)

in which n is the sample size. If the underlying population were normally distributed ( [image] =0), and if [image] and S were the ordinary sample mean and standard deviation, then the random variable on the left-hand side of the inequality would have the noncentral t distribution with n-1 degrees of freedom and noncentrality parameter [image] (k [image],p). If the underlying population had small skew, if the sample were large, and if the population skew coefficient, [image], could be replaced by the Bulletin 17B estimated skew coefficient, GW, then it could be assumed that the variate would have approximately the noncentral t distribution. Building upon this foundation, one obtains:

(21)

which is the noncentral t value with exceedance probability l- [image]. A standard large-sample approximation for the noncentral t distribution then yields the result:

(22)

in which k(1 - [image]) is the standard normal deviate with exceedance probability 1- [image] and GW is the Bulletin 17B weighted-skew coefficient. As stated above, an [image] -value near unity yields upper confidence limits whereas a value near zero yields lower limits. This result is equivalent to that in the Bulletin 17B guidelines.


Probability-Plotting Positions

 Probability plotting positions are estimates of the exceedance probabilities of observed peak flows. They are computed by the formula p = (m-a)/(N-2a+1) (equation 10 in Bulletin 17B), in which m is the rank of an observed peak (m = 1 for highest peak), N is the sample size, and a is a constant characteristic of a particular plotting-position formula. Bulletin 17B and Program PeakFQ use the Weibull plotting-position formula (a = 0) by default, although other a-values can be specified. The probability-plotting positions are not used in the Bulletin 17B computations, but are used in graphic displays of the observed data in relation to the fitted frequency curve.

If there is historical information, the probability-plotting positions are adjusted using the same logic that underlies the calculation of the historically-weighted mean, standard deviation, and skew coefficient. The actual sample of size N is augmented by (W-1) “virtual” copies of the observed peaks below the historic threshold to fill out the entire historic period (H). In the ranked record, each below-threshold observed peak is preceded by (W-1)/2 of its virtual copies and followed by the remaining (W-1)/2 copies. In the augmented ranked series, if there are Z peaks above the historic threshold, the rank of the first below-threshold observed peak is Z + (W-1)/2 + 1. The rank of the second below-threshold observed peak is Z + W + (W-1)/2 + 1. In general, the historically-adjusted rank [image] of the m-th ranked observed peak is:

= | m | if m <= Z | (23)
= | Z + (m-Z-1)W + (W-1)/2 + 1 | if m > Z

The historically weighted plotting positons [image] then are:

= ( [image] - a ) / ( H -2a + 1 )(24)

These equations are equivalent to equations 6-6 - 6-8 in Appendix 6 of Bulletin 17B. As indicated above, Program PEAKFQ uses the Weibull plotting position formula (a = 0) by default, although other a-values can be specified.


Estimation of Generalized Skew Coefficient

 The skew of a frequency distribution has a great effect on the shape and thus the values of the distribution, particularly in the extreme tail, which is of most concern in flood risk estimation. The skew coefficient of the station record (station skew coefficient, G) is sensitive to extreme events; thus it is difficult to obtain an accurate estimate of the skew coefficient from a small sample. The accuracy of the estimated skew coefficient can be improved by weighting the station skew coefficient with a generalized-skew coefficient estimated by pooling information from nearby sites.

Program PEAKFQ does not perform generalized skew estimation. It either looks up the generalized skew in a digitized version of the map (Plate I) in Bulletin 17B or reads it and its associated root mean square error (RMSE) from user-supplied input. The estimation of the generalized skew is performed by the flood-frequency analyst.

The discussion in this section concerns Bulletin-17B guidelines for development of appropriate generalized-skew coefficients for flood frequency analysis. The following discussion is modified from Bulletin 17B (p. 10-14).

Bulletin 17B includes a map (Plate I) showing generalized skew values that may be used in the absence of detailed generalized skew studies. This map and its corresponding mean square error (MSE) of 0.302 (RMSE = 0.550) were developed when Bulletin 17 was first introduced in 1976 and have not been updated.

Additional peak flow records have become available since that time. Also, the procedures used to develop the map do not conform in all respects to Bulletin 17B. Generalized skew estimates developed in accordance with Bulletin 17B procedures should preferably be used if available. Nonetheless, Plate I is still considered an alternative for use with Bulletin 17B for those who prefer not to develop their own generalized skew estimates. Program PeakFQ contains a digitized version of this map which is used if the user does not specify a generalized skew and RMS error.

The Bulletin-17B recommended procedure for developing generalized-skew coefficients requires the use of at least 40 stations, or all stations within a 100-mile radius. The stations used should have 25 or more years of record. It is recognized that in some locations a relaxation of these criteria may be necessary. The actual procedure includes analysis by three methods: (1) skew isolines drawn on a map; (2) skew prediction equation; and (3) the mean skew coefficient from selected stations. Each of the methods is discussed separately.

To develop the isoline map, plot each station skew coefficient at the centroid of its drainage basin and examine the plotted data for any geographic or topographic trends. If a pattern is evident, then isolines are drawn and the average of the squared differences between observed and isoline values, mean-square error (MSE), is computed. The square root of the MSE (RMSE or RMS error) should be computed to permit a better appraisal of the expected magnitude of the discrepancy between the generalized and station skews relative to the absolute magnitude of the skews. The MSE or RMSE will be used in appraising the accuracy of the isoline map. If no pattern is evident, then an isoline map cannot be drawn and is, therefore, not further considered.

A prediction equation should be developed that would relate either the station skew coefficients or the differences from the isoline map to predictor variables that affect the skew coefficient of the station record. These would include watershed and climatologic variables such as drainage area, channel slope, and precipitation characteristics. The prediction equation should preferably be used for estimating the skew coefficient at stations with variables that are within the range of data used to calibrate the equation. The MSE (or RMSE) should be computed as the average (or square root of the average) of the residuals between the observed station skews and the fitted relation. If the relation is fitted by linear regression, the standard error of regression can be taken as equivalent to the RMSE. The MSE (or RMSE) will be used to evaluate the accuracy of the prediction equation.

Determine the arithmetic mean and variance (or standard deviation) of the skew coefficients for all stations. In some cases, the variability of the runoff regime may be so large as to preclude obtaining 40 stations with reasonably homogeneous hydrology. In these situations, the arithmetic mean and variance of about 20 stations may be used to estimate the generalized-skew coefficient. The drainage areas and meteorologic, topographic, and geologic characteristics should be representative of the region around the station of interest. The variance (or standard deviation) is taken as comparable to the MSE (or RMSE) and is used to appraise the accuracy of the mean value as a prediction of the skew.

Select the method that provides the most accurate estimate of the skew coefficient. Compare the MSE from the isoline map to the MSE for the prediction equation. The smaller MSE should then be compared to the variance of the data. If the MSE is significantly smaller than the variance, the method with the smaller MSE should be used and that MSE used in equation 15 to predict the weighted skew coefficient. If the smaller MSE is not significantly smaller than the variance, neither the isoline map nor the prediction equation provides a significantly more accurate estimate of the skew coefficient than does the mean value. In this case the mean skew coefficient should be used as it provides as accurate an estimate as the more complicated alternatives; the variance should be used in equation 15 for the MSE of the generalized skew MSE [image] .

The accuracy of a regional generalized skew relationship is generally not comparable to the accuracy accuracy of Plate I in Bulletin 17B. While the average accuracy of Plate I is given, the accuracies of subregions within the United States are not given. A comparison should only be made between relationships that cover approximately the same geographical area.


Computer Program

 The following sections describe the computer program PeakFQ for performing the Bulletin 17B flood-frequency analysis. There are two methods for running PeakFQ: a windows version (called PKFQWin) and a batch version.


Windows Version (PKFQWin)

 The progroam PKFQWin provides a user interface to the PeakFQ batch model. The opening screen of the program is shown below.

When first opened, most of the interface is disabled. The interface is designed to follow a logical procession toward running PeakFQ: Use the File:Open menu item to open a PeakFQ data file. View/edit the Station Specifications that are populated by the data. View/edit the Output Options. Click the Run PEAKFQ button and View Results. Click the Save Specs button to store a desired set of specifications for future use.


File Open

 The File:Open menu item is used to open any of the file types that can be used by PeakFQ. These include:
  • Standard WATSTORE format Peak Flow data, as described in Appendices B.2, B.3, and B.4.
    Data in this format can be found on the NWIS-Web at http://nwis.waterdata.usgs.gov/usa/nwis/peak.
  • Watershed Data Management (WDM) files, as described in Appendix C.
  • PeakFQ Specification (PSF) files, as described in Appendix B.1.

Selecting the File:Open menu item opens the Open PeakFQ File dialogue. As seen here, this dialogue can open any of the three file types discussed above. After opening a file, the Station Specifications tab will be populated based on the contents of the file. Initial station specification values are derived from different sources for the three file formats:

  • WATSTORE - station header, station option, and peak-flows records
  • WDM - data and attributes from each station's data set
  • PSF - data file (WATSTORE or WDM) plus specifications for overriding initial values


Station Specifications

 Once the selected data file has been opened and read, the Station Specifications tab is populated.

The default values on the Station Specifications tab are determined by the contents of the input file, including any WATSTORE “I” records or WDM attributes that may be present. The default values may be further updated if a PSF file was opened that contains station specifications for overriding defaults. The example above shows many of the different options for the various fields. In particular, note how the same station may be run multiple times with different options between the runs (see Station IDs 03606500, 06600500, and 11274500 in the example).

By default all stations found on the data file will be Included in the Analysis. If a station is not to be analyzed, the Include in Analysis? field may be changed to No by either typing "No" or double-clicking to activate the pull-down menu.

By default, the Beginning Year and Ending Year fields contain the water years of the first and last, respectivley, peaks in the input file for the station. If a WATSTORE “I” record or WDM attribute is present, positive values in the Beginning Year and (or) Ending Year fields will be provided as the defaults. This will determine the period of record to be used in the calculations. These fields may be updated interactively by clicking in the desired station row and typing the new value.

The Historic Period field displays the value of any historic-period length specified in a Watstore "I" record or WDM attribute. If no value is specified, a value of 0 is displayed. A positive value must be displayed in this field for a Bulletin-17-B historic-record/high-outlier adjustment to be performed. If the historic-record/high-outlier adjustment is not performed, historic-coded peaks are ignored and any high outliers are treated as normal systematic peaks. The historic-period length is the sum of the number of years in the systematic-record period and the number of years in the non-systematic record period. The Historic-Period field may be updated interactively by clicking in the desired station row and typing the new value.

The Skew Option is, by default, "Weighted" between "Station" and "Generalized" skews (WTD, Bulletin 17B weighted skew.) If a WATSTORE “I” record or WDM attribute is present with a station option code of S or G, the default skew option code will be "Station" or "Generalized". The three options are available for selection in a pull-down menu in the Skew Option field.

The Generalized Skew is, by default, based on the station latitude and longitude using the generalized-skew map accompanying Bulletin 17B. If a WATSTORE "I" record or WDM attribtute is present and the generalized skew field is non-blank, that value will be provided as the default. This field may be updated interactively by clicking in the desired station row and typing the new value.

The Gen Skew Std Error field is, by default, 0.55, corresponding to the standard error of the generalized-skew map accompanying Bulletin 17B. If a WATSTORE “I” record or WDM attribute is present and the standard error of generalized-skew field is non-blank, that value will be provided as the default. This field may be updated interactively by clicking in the desired station row and typing the new value.

The Lo-Outlier-Threshold field displays the value of any user-specified low-outlier threshold that may have been present in a WATSTORE "I" record or WDM attribute. If no user-specified value has been given, then a value of 0.0 is displayed, and the low-outlier threshold is computed by PeakFQ using the Bulletin 17-B low outlier test. Any input peaks less than the low-outlier threshold are accounted for by the conditional-probability adjustment. Occasionally it may be necessary or appropriate to override the Bulletin-17-B low outlier test if, for example, the test criterion is very close to one of the input peaks or if there are several very low peaks. The Low-Outlier-Threshold field may be updated interactively by clicking in the desired station row and typing the new value.

The Hi-Outlier Threshold field displays the value of any user-specified historic/high-outlier threshold that may have been present in a WATSTORE "I" record or WDM attribute. If no user-specified value has been given, then a value of 0.0 is displayed. This field is used only if the Bulletin-17-B historic-record adjustment has been specified by the user in the Historic-Period field. If a value greater than zero is displayed in the Hi-Outlier-Threshold field, that value will be used as the historic/high-outlier threshold in the Bulletin-17-B historic-record adjustment. Otherwise, the lowest historic-coded input peak will be used as the historic/high-outlier threshold. If there are no historic-coded peaks and a historic adjustment for a high outlier is needed, the user must specify the required high-outlier threshold. The Hi-Outlier-Threshold field may be updated interactively by clicking in the desired station row and typing the new value.

The Gage Base Discharge represents the lower limit of measureable flood peak at a station; this is 0.0 by default. If a WATSTORE “I” record or WDM attribute is present, a positive value in the field will be provided as the default. A negative or zero value will be ignored by the program. If positive, this gage base discharge will supersede the gage base inferred from any “less than” NWIS qualification code (4) in the peak record. Note that this gage base discharge is not the same as the partial-duration base discharge that may be in the station header “Y” record. This field may be updated interactively by clicking in the desired station row and typing the new value.

By default, Urban and (or) Regulated Peaks are not ("No") included in the computations . These peaks are indicated by a "6" or "C" in the NWIS qualification code field. If a WATSTORE "I" record or WDM attribute is present, this field will default to "Yes" if the Station option field contains a "K".

The Latitude and Longitude fields contain, by default, the values from the WATSTORE station header “H” record or the WDM attributes. They are used to compute the generalized skew if it is not entered. These fields may be updated interactively by clicking in the desired station row and typing the new value.

The Lowest Historic Peak and Highest Systematic Peak fields are informational and cannot be modified. These values are determined from the peak record for the station.


Output Options

 The Output Options tab is used to modify options for output that will be used for all of the stations processed. These include the output file name, saving additional output to other files, including additional information in the output file, plot types and styles, and confidence limits.

If the Watstore check box is selected for additional output, the name for that file may also be specified.

Within PKFQWin, a variety of graphic plot formats are available. These include:

  • Computer Graphics Metafile ( CGM)
  • PostrScript ( PS)
  • Raster Bitmap ( BMP)
  • Windows Metafile ( WMF)


Results

 The Results tab allows viewing of the various forms of PeakFQ results. These include the main output file, the additional output file (if in use), and graphic plots.

The View buttons in the Output File and Additional Output frames are used to open those files for viewing. The files will be viewed with the system's default viewer of Text files.

The Graphs list displays the available plots from the stations that were analyzed. This list is only populated if the user selects something other than None for the Graphic Plot Format on the Output Options tab. The default base file names are the station ID. If a station is analyzed more than once, an index is attached to the station ID to make its graph name unique. The graph file names may also be edited by selecting the desired name and entering a new name. The View button under the list of graphs will cause the selected graphs to be displayed, each in a separate window.

The graphs viewed from the PKFQWin interface are in Bitmap (BMP) format. If, on the Output Options tab, the user selected another graphic format (e.g. CGM, PS, WMF), the graphs will also be stored in that selected format for use outside of PeakFQWin. The Bitmap files will not be saved for later use unless that was the selected graphic format.


Save Specs

 The Save Specs feature (menu option or command button) allows the user to save a set of specifications for future use. The specifications from the last PeakFQ run will be written to a PSF file. The PSF file will contain only specifications which are not the default values for the run.


Batch Version

 The PeakFQ batch program is run from a DOS prompt by typing the executable file name followed by an input specification file. It may be desirable to pipe the output to a file to capture any messages. For example:

PEAKFQ TEST2.PSF>TEST2.RUN

Paths to any of these files may also be included.

The batch program is given instructions for the run through the PeakFQ specification file (*.psf). The .psf extension is not required, but is useful for file organization. The only required elements of the specification file are the input data file and the output file. Thus, the simplest example of a specification file might look like this:

I ASCI Test2.inp
O FILE Test2.OUT

Defaults for all output and station specifications are defined in the code. These specifications may then be updated by the input data file either through Watstore “I” cards or WDM attributes. Finally, specification updates may be made through the PeakFQ specification file.

Details of all specification file elements are found in Appendix B.1.


References Cited

Beard, L.R., 1960, Probability estimates based on small normal-distribution samples: Journal of Geophysical Research, v. 65, no. 7, p. 2143-2148.

Flynn, K.M., Hummel, P.R., Lumb, A.M., and Kittle, J.L., Jr., 1995, Users manual for ANNIE, version 2, a computer program for hydrologic data management: U.S. Geological Survey Water-Resources Investigations Report 95-4085, 211 p., http://water.usgs.gov/software/annie.html.

Interagency Advisory Committee on Water Data, 1982, Guidelines for determining flood-flow frequency: Bulletin 17B of the Hydrology Subcommittee, Office of Water Data Coordination, U.S. Geological Survey, Reston, Va., 183 p., http://water.usgs.gov/osw/bulletin17b/bulletin_17B.html.

Lepkin, W.D., DeLapp, M.M., Kirby, W.H., and Wilson, T.A., 1979, National Water Data Storage and Retrieval System WATSTORE User's Guide: U.S. Geological Survey Open-File Report 79-1336-I, v. 4, ch. I, secs. A, B, and C.

Tasker, G.D., 1978, Flood Frequency Analysis with a Generalized Skew Coefficient: Water Resources Research, v. 14, no. 2, p. 373-376.

Wallis, J.R., Matalas, N.C., and Slack, J.R., 1974, Just a Moment: Water Resources Research, v. 10, no. 2, p. 211-219.


Appendix A. PeakFQ Diagnostic Messages

Diagnostic messages are produced when real or potential errors are detected. The diagnostic messages included in the PeakFQ output file are substantially the same as those produced by the original J407 procedure in WATSTORE (Kirby, W.H., 1981, Annual flood frequency analysis using U.S. Water Resources Council guidelines (program J407): U.S. Geological Survey Open-File Report 79-1336-I, WATSTORE User's Guide, v. 4, chap. I, sec. C, 56 p.). These messages are listed and briefly explained below.

Most of the messages have the following general format:
***iiinnns - text data
in which:
*** | represents a variable number, possibly zero, of asterisks, to call attention to the message
iii | identifies the general part of the program producing the message as follows: INP - input processing PKF - reading the peak flow file retrieval records (WATSTORE card format) WCF - flood frequency calculations following Bulletin 17B guidelines
nnn | is a message number. The messages are listed below approximately in alphabetic and numerical order by identifier and number
s | is a severity indicator. E means error, W means warning, I and J mean routine information, and L means listing of data or results
text | is the text of the message
data | is a list of numbers or words generally in the same order as items mentioned in the text

The messages are listed below approximately in alphabetic and numerical order by identifier and number.

FRQPLT | WILL DROP POINTS BELOW PLOT BASE.
 | One or more points on the computed empirical frequency curves fall below the lower boundary of the plot. These points will not be plotted.
INPUT2 | HISTORIC PEAKS OVERFLOWED. nhp i sta-id
 | The number of historic peaks (nhp) retrieved for station (sta-id) exceeds the capacity of program PeakFQ (20 historic peaks). Possible system error: check the input for validity; if there are more than 20 historic peaks (code 7), notify h2osoft@usgs.gov.
INPUT2 | REQUESTED YEARS NOT IN RECORD. beg-yr end-yr first-yr last-yr sta-id
 | Probable user error. The years requested on the I-card (beg-yr, end-yr) do not overlap the years available in the record (first-yr, last-yr) at the station (sta-id).
INPUT2 | STATION HAS NO PEAK FLOW DATA. STA-ID = xxxxx
 | Informative message. See preceding messages for explanation. Processing continues with next valid input record.
INPUT2 | PEAK COUNT EXCEEDS STORAGE CAPACITY npks sta-id
 | The number of peaks (npks) retrieved fro station (sta-id) exceeds the capacity of program PeakFQ (200 peaks). Possible system error: check the input for validity; if there are more than 200 peaks, notify h2osoft@usgs.gov.
PKFRD4 | PEAK OVERFLOW. NPKS,MAX = n max
 | The number of peaks (n) exceeds the storage capacity (max) of program PeakFQ. Probable system error; notify WATSTORE User assistance.
PKFRD4 | Insufficient data to process, only nnn peaks for station sta-id
 | Only nnn peaks were identified to be include in the analysis for station id sta-id. A minimum of 3 peaks is required.
PKFRD4 | CARD types 4, 2, and * are ignored.
 | card-image
PKFRD4 | Unrecognized CARD type. Must be Y, Z, N, H, I, 2, 3, 4, or *.
 | (2, 4, and * records are ignored.)
 | card-image
PKFRD4 | Error reading input lat. or long. on H card.
 | card-image
PKFRD4 | Error reading I-card
 | card-image

WCF001J | FLOOD FREQUENCY, BULLETIN 17-B. VER n.n (dddddd).
Unedited machine computations. User is responsible for interpretation and use. n.n (dddddd) = version number and date of last revision. Normal beginning-of-job message, if requested.
WCF002J | CALCS COMPLETED. RETURN CODE = n
Normal end-of-job message . Return codes: 0 = no error detected. 1 = non-standard data accepted, 2 = warning -- calculations completed, but results may be incorrect.
WCF003E | CALCS ABORTED. RETURN CODE = 3.
WCF … Routines were unable to complete the calculations for reasons explained in previous messages.
WCF004* | INTERNAL PROGRAM LOGIC ERROR. Location-code data
This message should not occur. If it does, contact h2osoft@usgs.gov
WCF101L
INPUT PARAMS | GENSKU | OPT | GS.ERR | GAGEB | QLWOUT | QHIOUT | NHIST | HISTPD
 | xxx | xxx | xxx | xxx | xxx | xxx | xxx | xxx
Routine listing of input data, if requested.
WCF102E | INVALID PEAK COUNTS. NPK, NHIST = nnn nnn
Either the number of historic peaks (HNIST) is negative or the total number of input peaks is less than NHIST. Probable error in counting input peaks.
WCF103L | INPUT PEAKS, HISTORIC FIRST. TOTAL NO. = nnn
Routine listing of input data, if requested.
WCF104L | INPUT LOG PKS, HIST FIRST. TOTAL NO. = nnn
Routine listing of input data, if requested.
WCF107I | ACCEPTED GENSKEW OUTSIDE MAP LIMITS GS m1 m2
Input generalized skew GS was outside range of values (m1, m2) set at program installation time. (Limits of Bulletin 17B skew map.)
WCF109W | PEAKS WITH MINUS-FLAGGED DISCHARGE WERE BYPASSED. nnn
nnn negative input peaks were found. These are assumed to be codes for unknown discharges. These peaks are ignored in the computations, but large negative values are stored in corresponding locations in output logarithm vector. If the input has any unknown discharges coded as negative values, ensure that these peaks legitimately can be ignored. Otherwise, incorrect input peak counts may cause this message. Warning only--analysis continues.
WCF111E | HISTORIC PEAK HAD MINUS-FLAGGED DISCHARGE .
One of the historic peaks was negative. Probable error in input data value or count.
WCF113W | NUMBER OF SYSTEMATIC PEAKS HAS BEEN REDUCED TO NSYS - nnn
Missing-discharge peaks were noted and have been omitted from the sample (WCF109). The correct sample size for analysis is nnn.
WCF117E
NO DATA IN SYST RECORD. | NSYS | NPK | NHIST | NMISS
 | xxx | xx | xxx | xxx
There is no systematic record at this station. Possible error in input data or input peak count. NPK = total number of input peaks. Other as in list of variables.
WCF118W | SYSTEMATIC RECORD SHORTER THAN 17B SPEC. nnn
Systematic record length nnn is less than that specified in Bulletin 17B. Analysis proceeds, but sample size may be too small for reliable conclusions.
WCF133I | SYSTEMATIC PEAKS BELOW GAGE BASE WERE NOTED. nnn bbb
nnn = number of below-gage-base peaks. bbb = gage-base-discharge.
WCF134I | NO SYSTEMATIC PEAKS WERE BELOW GAGE BASE. bbb
bbb = gage-base discharge.
WCF141ESAMPLE SIZE TOO SMALL TO CALC STATS. lll nnn
NSYS, | NBG, | NLWOUT, | NHIOUT, | NHISTN, | HISTPN
xxx | xx | xx | xx | xx | xx
Either the systematic or the Bulletin 17B-adjusted record is too short for calculation of mean, variance, and skew (less than 3 items). Probable cause -- insufficient record length or excessively high gage base or user low-outlier criterion. lll = either SYS (systematic) or 17B. nnn = effective sample size. Others as in list of variables.
WCF143E | NEGATIVE VARIANCE OF LOGS. lll vvv
lll = either SYS (systematic) or 17B. vvv = the computed variance (should be near zero). Probable cause -- roundoff error in computing near-zero variance when all input peaks are (nearly) equal.
WCF151I | 17B WEIGHTED SKEW REPLACED BY USER OPTION. www uuu igsopt
Bulletin 17B weighted skew calculation (www) has been superseded by user-specified skew uuu. An igsopt value of 1 means generalized skew; -1 means station skew.
WCF156I | 17B HIGH-OUTLIER TEST SUPERSEDED BY MIN HIST PK. www
Routine information report of Bulletin 17B high-outlier test criterion (www). Historic peaks were present below this threshold, so the historic-high-outlier threshold was lowered to the level of the smallest historic peak.
WCF157W | USER HIGH-OUTLIER CRIT LOWERED TO MIN HIST PK. uuu hhh
Probable user error -- if historic peaks are given. The high-outlier base need not be set unless peaks smaller than the smallest historic peak are to be treated as high outliers. uuu = user high outlier criterion. hhh minimum historic peak.
WCF159E | HIGH-OUT/HIST-PK BASE BELOW LOW-OUT/GAGE BASE. hhh lll
Probable user error--perhaps the high-outlier and low-outlier or gage-base data have been entered in the wrong order. hhh = high-outlier or historic base. lll = low-outlier or gage base.
WCF161I | USER HIGH-OUTLIER CRITERION REPLACES 17B. uuu www
The user-specified historic-peak-high-outlier discharge threshold (uuu) has been noted. Its value supersedes the Bulletin 17B-recommended value (www).
WCF162I | SYSTEMATIC PEAKS EXCEEDED BY HIGH-OUTLIER CRITERION. nho hhb
One or more (nho) systematic peaks exceeded the high-outlier discharge criterion (hhb) No historic adjustment was applied because the user did not specify the length of the historic period.
WCF163I | NO HIGH OUTLIERS OR HISTORIC PEAKS EXCEEDED HHBASE. hhb
No high outliers or historic peaks were detected. The historic-peak-high-outlier discharge threshold is hhb.
WCF164W | HISTORIC PERIOD IGNORED. histpd
A historic period length (histpd) was specified, but no high outliers or historic peaks were found. The historic period length is ignored and no Bulletin 17B historic adjustment is attempted. Probable user error--the historic period length should not be specified unless one or more historic peaks or high outliers are present.
WCF165I | HIGH OUTLIERS AND HISTORIC PEAKS ABOVE HHBASE. nho nhp hhb
Historic adjustment was applied. nho = number high outliers noted, nhp = number historic peaks, hhb = high outlier/historic base flow.
WCF167E | HSIST PERIOD NO LONGER THAN SYS+HIST PEAKS. hhh nnn
Stated historic period hhh is no longer than actual count of observed peaks nnn. Probable user error - if both hhh and nnn are correct there is no point in doing the historic adjustment.
WCF169I | ACCEPTED HISTORIC PERIOD GTR THAN T hhh ttt
The historic period hhh may be longer than can be justified under the Bulletin 17B criteria for historic information. T = 5 * systematic record, up to max of 300 yrs.
WCF171W | NUMBER HI-OUT/HIST PKS EXCEEDS 10PCT OF SYS.PKS. nho nhp
Excessive number of historic peaks nhp and high outliers nho suggest that historic base may be set too low to ensure that every peak exceeding it has been recorded.
WCF191I | USER LOW-OUTLIER CRITERION SUPERSEDES 17B. uuu www
uuu = user low-outlier criterion, www = Bulletin 17B low-outlier criterion
WCF193E | LOW OUTLIER CRITERION EXCEEDS HIGH-HIST lll hhh
Probable user error--perhaps the high-outlier and low-outlier or gage-base data have been entered in the wrong order. hhh = high-outlier or historic base. lll - low-outlier or gage base.
WCF195I | NO LOW OUTLIERS WERE DETECTED BELOW CRITERION xxxxx
No peaks above the gage base were below the low-outlier criterion. xxxxx = low outlier criterion adopted (user or 17B).
WCF198I | LOW OUTLIERS BELOW FLOOD BASE WERE DROPPED. nnn bbb
Peaks above the gage base and below the low-outlier criterion were noted. The flood base of the Bulletin 17B frequency curve has been set at the low-outlier criterion. nnn = number of low outliers dropped. bbb = Bulletin 17B flood base.
WCF199W | NUMBER OF PEAKS BELOW FLOOD BASE EXCEEDS 17B SPEC. nbb bbb maxnbb
Bulletin 17B specifies a maximum number of peaks that may fall below the flood base for this length of systematic record. The actual number nbb of below-base peaks exceeds this limit (maxnbb). The flood base = bbb. Warning - the calculation proceeds but the results may be unreliable.
WCF213E | COND PROB ADJUST FAILED - EXCESSIVE lll PROB BELOW BASE. ppp
The conditional probability adjustment described in appendix 4 of Bulletin 17B cannot be performed when ppp fraction of the peaks are below the flood base. lll = (SYS for systematic rec freq curve, in which case flood base = gage base) or 17B.
WCF215E | SKEW OUT OF TABLE RANGE. lll skew-a skew-u gensku
One or more of the skews to be used in constructing the Pearson Type III curve for either the systematic or Bulletin 17B record is out of the range of the Bulletin 17B Pearson Type III table (+ or - 9.0). lll = either SYS or 17B. Skew-a is the skew of the above base peaks. skew-u and gensku may not be present. skew-u is the unconditional skew after any conditional probability adjustment or weighted-skew calculation. gensku is the generalized skew, and is printed only if the error is detected after the Bulletin 17B weighted-skew calculations.
WCF217L
FREQUENCY CURVE PARAMS lll xxx | xxxxx | xxxxx | xxxxx
 | xxxxx | xxxxx | xxxxx
Routine report of frequency curve parameters for curve lll (SYS or 17B). Parameters are -- probability of exceeding base; mean, standard deviation, and skew of frequency curve (unconditional -- after a conditional probability adjustment, if P (BASE) is less than 1.0); mean, standard deviation, and skew of above-base peaks (before conditional probability adjustment).
WCF219J
FREQ CURVE ORDINATES lll | 2-YR(.50) | 10-YR (.10) | 100-YR (.01)
 | xxxxxxx | xxxxxxx | xxxxxxx
Routine report of frequency curve ordinates at 2-yr, 10-yr, and 100-yr levels for lll (SYS or 17B) frequency curve.
WCF233W | EXPECTED PROB OUT OF RANGE AT TAB PROB xxxxx yyyyy
Expected-probability calculation called for table lookup at expected probability xxxxx beyond the limits of the computed Bulletin 17B frequency curve. This message normally occurs several times when sample size is less than about 10 years and tabular probability yyyyy is less than about 0.10.
WCF238J | FREQ CURVE 17B-EXPECT PROB xxxxxxx xxxxxxx xxxxxxx
Routine report of 'expected-probability'frequency curve ordinates at 2-, 10-, and 100-yr levels. 'Expected-probability' curve is based on Bulletin 17B frequency curve.
WCF239J
FREQ CURVE CONF LIMS 17B xx.x | xxxxxxx | xxxxxxx | xxxxxxx
 | xxxxxxx | xxxxxxx | xxxxxxx
Upper and lower confidence limits for Bulletin 17B frequency curve ordinates reported in WCF219. xx.x = one-sided confidence level.


Appendix B. PEAKFQ Data Formats

 Appendix B contains detailed documentation of files used by PeakFQ.

Appendix B.1 describes the PEAKFQ specification file used to run the batch program.

Appendices B.2 - B.4 describe the different sections of the WATSTORE data files used by PeakFQ.

  • Appendix B.2 describes the station header records
  • Appendix B.3 describes the station option records
  • Appendix B.4 describes the peak-flows records


Appendix B.1. Batch Specifications

 This appendix gives detailed descriptions of the PeakFQ specification (PSF) file. Running the batch version of PeakFQ, whether stand-alone or from the PKFQWin interface, requires a specification file as a command line argument.

There are only two required records in PeakFQ specification files. These are the input data file and the main output file.

The input data file record must start with "I", followed by either the "ASCI" (for Watstore text files) or "WDM" (for WDM files) keyword, followed by the name of the input data file. Here are examples of each:

I ASCI Test2.inp

I WDM Test.wdm

The main output file record must start with "O", followed by the "FILE" keyword, followed by the output file name. For example:

O FILE Test2.out

Other output specification records (also starting with "O"), are used to define output options that apply to the entire run. These specifications are described in the following table.

Keyword | Valid Values | Default | Description
DEBUG | YES NO | NO | YES provides additional printout of intermediate results in the analysis.
ADDITIONAL | WDM WAT BOTH NONE | NONE | WDM - puts computed statistics on each data set as attributes for further statistical analysis. WATSTORE - puts computed statistics on file in a format for input to WATSTORE basin characteristics.
EMA | YES NO | NO | NO will run the traditional Bulletin 17B analysis. YES will run the new EMA analysis.
CONFIDENCE | 0.nn | 0.95 | Where 0.nn is confidence limit percent as a fraction.
PLOT STYLE | GRAPHICS PRINTER BOTH NONE | NONE | GRAPHICS (or BOTH) will generate a graphic file for each station analyzed. PRINTER uses ASCII character set on a line printer, 132 characters wide.
PLOT FORMAT | CGM PS BMP WMF | CGM | Format for GRAPHIC plots
PLOT PRINTPOS | YES NO | YES | YES provides an additional table in the printout listing the observed peaks and assigned recurrence intervals.
PLOT POSITION | 0.nn | 0.00 | Plotting position computed as (m-a)/(N+1-2a) where m is order number, N is total number of peaks, and a is a parameter where: a = 0.0 for Weibull a = 0.30 for Median/Beard a = 0.375 for Blom a = 0.4 for Cunnane a = 0.44 for Gringorten

The remaining specifications are made for each station being analyzed in the run. If specifications are to be made for a station, the first record must indicate the station to which the specifications apply:

STATION <staid>

where

<staid> is either the alphanumeric Station ID from the WATSTORE file or the data-set number from the WDM file.

The following table describes the available station specifications.

Keyword | Valid Values | Default | Description
GENSKEW | n.nnn | From Generalized skew map using lat/lng | Where n.nnn defines the estimated skew based on experience at nearby stations or regional analysis.
SKEWSE | n.nnn | 0.55 | Where n.nnn defines the standard error of the generalized skew. If not specified, the standard error of the generalized skew map, 0.55, will be used.
BEGYEAR | nnnn | From data file | Where nnnn defines the first water year of data to be used in the analysis.
ENDYEAR | nnnn | From data file | Where nnnn defines the last water year of data to be used in the analysis.
HISTPERIOD | nn | 0.0 | Where nn defines the length of historic period in years (entering 0.0 will cause the historic peaks to be ignored). Must be greater than the systematic period.
SKEWOPT | GENERALIZED WEIGHTED STATION | WEIGHTED | STATION - station skew computed from recorded peaks GENERALIZED - generalized skew from map or regional analysis WEIGHTED - weighted between STA and GEN
URB/REG | YES NO | NO | Peaks affected by urban development or upstream regulation will be ignored unless this is YES.
LOHIST | nnnn | 0.0 | Where nnnn displays the lowest historic peak. This value is only informational for display in the PKFQWin interface.
LOTHRESH | nnnn | 0.0 | Where nnnn defines the low-outlier discharge criteria. If greater than 0.0, will override the Bulletin 17-B computed low-outlier criteria.
HISYS | nnnn | 0.0 | Where nnnn displays the highest systematic peak. This value is only informational for display in the PKFQWin interface.
HITHRESH | nnnn | 0.0 | Where nnnn defines the historic high-outlier discharge threshold (entering 0.0 will cause the historic peaks to be ignored). This discharge will override the Bulletin 17-B computed high-outlier threshold.
GAGEBASE | nnnn | 0.0 | Where nnnn defines the lower limit of measurable flood peak discharge. If greater than 0.0, will supersede the gage base discharge inferred from any "less than" qualification codes.
LATITUDE | nn.nn | From data file | Where nn.nn defines latitude, in degrees, for computing generalized skew.
LONGITUDE | nnn.nn | From data file | Where nnn.nn defines longitude, in degrees, for computing generalized skew.
PLOTNAME | Valid file name | None | Base file name for graphic plot.

This sequence of a STATION record followed by any desired specifications is then repeated for each station to be analyzed in the run.

Two additional keywords may be found in PSF files, particularly those generated and used by PKFQWin. These are VERBOSE and UPDATE. The VERBOSE keyword will only be found at the start of a PSF file and indicates that all possible specifications are written out in the file, even if they are the default value. The UPDATE keyword will only be found at the end of a PSF file and indicates that as PeakFQ performs the run, it should write out the PSF file in VERBOSE mode.

The following sample PSF File is written in VERBOSE mode and contains just the first station from the Test2.inp sample data file.

I ASCI TEST2.INP
O File TEST2.OUT
O Plot Style None
O Plot PrintPos Yes
O Plot Position 0.00000
O Additional None
O Debug No
O EMA No
O Confidence 0.950000
Station 03606500
SkewOpt Weighted
GenSkew -0.500000
SkewSE 0.550000
BegYear 1897
EndYear 1973
HistPeriod 0.00000
Urb/Reg No
LoThresh 0.00000
HiThresh 0.00000
GageBase 0.00000
Latitude 36.0386
Longitude 88.2283


Appendix B.2. Station Header Records

 The Station header records are optional and contain some fields not read by program PeakFQ; for completeness, these fields are included in the description below. If latitude and longitude are not provided on an H record, latitude and longitude or generalized skew must be input elsewhere.

If included in the input file, the H, N, and Y records must contain the station identification number. The Record identifier is required for all records in the input file. Only fields described as required or optional are read by the PeakFQ program

recordcolumnformatWDM
attribute		description
Z Agency Identification Record - optional
1"Z"--Record identifier.
33-37 | A5 | AGENCY | Agency code as assigned by WATSTORE.
H Station Header Record - required
1"H"--Record identifier. Required
2-16 | A15 | STAID or ISTAID | Station identification number. Required
17-31---Station locator. Required
3I2 | LATDEG | Latitude, DDMMSS
I3,2I2 | LNGDEG | Longitude, DDDMMSS
I2 | Sequence number
32-33 | A2 | STFIPS | Numeric state code where station is located.
34-35 | A2 | DSCODE | For USGS sites only, the district (numeric state code) or the alpha project code of the office responsible for collecting and storing the data.
36-38 | A3 | COCODE | FIPS county code where the station is located.
39-40A2SITECOSite code indicating the major class of data collected at the site:
SW - stream | GW - well
SP - spring | LK - lake or reservoir
ES - estuary | ME - meteorological
41-48 | I8 | HUCODE | Hydrologic unit code from the USGS state hydrologic unit maps.
49-55 | F7.0 | DAREA | Total drainage area, in square miles.
56-62 | F7.0 | CONTDA | Contributing drainage area, in square miles.
63-70 | F8.0 | DATUM | Datum, feet above mean sea level.
71-79 | F9.0 | WELLDP | Well depth, in feet.
N Station Name Record - optional
N1"N"--Record identifier. Required
2-16 | A15 | STAID or ISTAID | Station identification number. Required
17-64 | A64 | STANAM | Station name. Required
65-72 | A8 | GUCODE | Major geologic unit codes as assigned by WATSTORE.
73A1AQTYPEAquifer type code assigned by WATSTORE:
U | - unconfined single aquifer
N | - unconfined multiple aquifers
C | - confined single aquifer
M | - confined multiple aquifers
X | - mixed multiple aquifers
Y Base Discharge Record - ignored.
1"Y"--Record identifier.
2-16 | A15 | STAID or ISTAID | Station identification number. Required
17-23 | F7.0 | BASEQ | Base discharge. (Note: this is not the Gage Base Discharge used in PeakFQ.)


Appendix B.3. Station Option Records

 The Station option record is optional. If included in the input file, the I record must contain the station identification number, all other fields are optional and may be left blank. Program PeakFQ reads all of the fields on this record. The description column below describes how blank fields are handled.

recordcolumnformatWDM
attribute		description
I Station option record - optional
1"I"--Record identifier
2-16 | A15 | STAID or ISTAID | Station identification number. Required
17-24 | Generalized skew. If not specified, the generalized skew will be determined based on gage latitude and longitude using the generalized skew map accompanying the Bulletin 17B guidelines.
25-32 | Length of historic period in years. A positive value must be supplied in order for the historic adjustment to be applied. The historic period contains the systematic record period as a subset. If this field is left blank, any input historic peaks will be ignored and any high outliers will be treated as normal systematic peaks.
33-40 | User-specified historic-high-outlier discharge threshold. Used only in conjunction with the historic period, this threshold is used to override the Bulletin 17B-computed high-outlier threshold. If this field is left blank, the Bulletin 17B threshold will be lowered automatically to equal the smallest historic peak(s) is one is known. If a positive value is specified in this field, all peaks that exceed this value will be used in the historic adjustment. Any historic peaks lying below this value will be ignored.
41-48 | User-specified low-outlier discharge criterion. This criterion, if a postive number, will override the Bulletin 17B computed low-outlier criterion. A blank, negative value, or zero will be ignored.
49-56 | Gage base discharge, representing a lower limit of measurable flood peak discharge at the site. This discharge, if a positive number, will supersede the gage base inferred from any "less than" qualification codes of the input peak flow records. A blank, negative value, or zero will be ignored. (The gage base discharge is not the same as the partial-duration base discharge that may be recorded in the Station Header record.
57-64 | Standard error for the generalized skew. If not specified, a value of 0.55, corresponding to the standard error of the generalized skew map accompanying the Bulletin 17B guidelines, will be used.
65-69Station-option codes selected from the following list. The codes may be in any order or combination and may be in any available column. In case of conflict, the rightmost code is used. The available options are:
S - | Station-skew option. Causes the station skew, adjusted for outliers and historic data, rather than the Bulletin 17B weighted skew, to be used for the final frequency curve.
G - | Generalized-skew options. Causes the generalized skew, rather than the Bulletin 17B weighted skew, to be used in the final frequency curve.
K - | Known regulation/urbanization input option. Allows peaks with the known regulation or urbanization codes (6 or C) to be included in the statistical analysis.
71-74 | Begin year: first water year of retrieved records to be included in the statistical analysis; earlier years are ignored. This value must be either blank or a four-digit number. If blank or less than the first year of the input record, no years will be dropped from the beginning of the record.
75-78 | End year: last water year of retrieved records to be included int the statistical analysis; later years will be ignored. This value must be either blank or a four-digit number. If blank or greater than the last year of the input record, no years will be dropped from the end of the record.


Appendix B.4. Peak-Flow Records

Peak flow records contain some fields not read by program PeakFQ; for completeness, the fields are included in the description below. The peak-flow records may be preceded by station header records.

  • Calendar year if columns 21-22 contain a valid month
  • Water year if columns 21-22 are blank or 99
This entry may or may not be the same as on the preceding type 3 record if one is present, but the month and year must have occurred in the same water year as the peak discharge.
recordcolumnformatWDM
attribute		description
3 Peak Flow Data Record - required. Fields in columns 44 - 75 are ignored.
1"3"--Record identifier. Required
2-16 | A15 | STAID or ISTAID | Station identification number.
17-20I4--Year peak occurred - required:
  • Calendar year if columns 21-22 contain a valid month
  • Water year if columns 21-22 are blank or 99
21-22I2--Month the annual peak discharge occurred. Blank if month is not known.
23-24I2--Day of the month the annual peak discharge occurred. Blank if day is not known.
25-31F7.0--Annual peak discharge, right justified. Field may be blank.
32-43A12--Annual peak discharge qualification codes. More than one code may be associated with a peak, except as noted below. Field may be blank.
1 - | discharge is a maximum daily average
2 - | discharge is an estimate
3 - | discharge affected by dam failure
4 - | discharge less than indicated value, which is minimum recordable discharge at this site *
5 - | discharge affected to unknown degree by regulation or diversion **
6 - | discharge affected by regulation or diversion **
7 - | discharge is a historic peak ***
8 - | discharge actually greater than indicated value
9 - | discharge due to snowmelt, hurricane, ice-jam or debris dam breakup
A - | year of occurrence is unknown or not exact
B - | month or day of occurrence is unknown or not exact
C - | all or part of the record affected by urbanization, mining, agricultural changes, channelization, or others
D - | base discharge changed during this year
E - | only annual maximum peak available for this year
* | Code 4 cannot occur simultaneously with codes 1, 2, 3, 7, or 8.
** | Codes 5 and 6 cannot occur simultaneously
*** | Code 7 should indicate that the value for the particular year is a historic peak and the particular year occurred before or after the systematic record, or during a break in the systematic record.
44-51F8.0--Gage height associated with annual peak discharge, right justified in field. Ignored.
52-55A4--Gage height qualification codes. More than one code may be associated with a gage height. Field may be blank. Ignored.
1 - | gage height affected by backwater
2 - | gage height not the maximum for the year
3 - | gage height at different site and/or datum
4 - | gage height below minimum recordable elevation
5 - | gage height is an estimate
6 - | gage datum changed during this year
* | If code 2 is given here, then a date and data entries should be made for the maximum annual gage height (cols 60-75).
56-59I4--"Highest since" year -- representing the calendar year after which the given peak discharge (cols 25-31) is known to be the highest. This year is determined from historic newspaper accounts, local information, or other sources.
60-61I2--Month in which the annual peak gage height occurred. While this month may not be in the same calendar year as the annual peak, it is that it is in the same water year.
62-63I2--Day of the month of the annual peak gage height.
64-71F8.0--Annual peak gage height.
72-75A4--Annual peak gage height qualification codes
1 - | gage height affected by backwater
3 - | gage height at different site and/or datum
5 - | gage height is an estimate
6 - | gage datum changed during this year
4 Partial Duration Peak Flow Data Record - Ignored.
1"4"--Record identifier. Required.
2-16 | A15 | STAID or ISTAID | Station identification number. Required.
17-20I4--Year data on this record occurred.
21-22I2--Month the partial duration peak occurred. Blank if month is not known.
23-24I2--Day of the month the partial duration peak occurred. Blank if day is not known.
25-31F7.0--Partial duration peak discharge, right justified.
32-43A12--Partial duration peak discharge qualification codes. More than one code may be associated with a peak.
1 - | discharge is a maximum daily average
2 - | discharge is an estimate
3 - | discharge affected by dam failure
4 - | discharge less than indicated value, which is minimum recordable discharge at this site *
5 - | discharge affected to unknown degree by regulation or diversion **
6 - | discharge affected by regulation or diversion **
7 - | discharge is an historic peak ***
8 - | discharge actually greater than indicated value
9 - | discharge due to snowmelt, hurricane, ice-jam or debris dam breakup
A - | year of occurrence is unknown or not exact
B - | month or day of occurrence is unknown or not exact
C - | all or part of the record affected by urbanization, mining, agricultural changes, channelization, or others
D - | base discharge changed during this year
E - | only annual maximum peak available for this year
* | Code 4 cannot occur simultaneously with codes 1, 2, 3, 7, or 8.
** | Codes 5 and 6 cannot occur simultaneously.
*** | Code 7 should indicate that the value for the particular year is a historic peak and the particular year occurred before or after the systematic record, or during a break in the systematic record.
44-51F8.0--Partial duration peak gage height.
52-55A4--Partial duration peak gage height qualification codes. More than one code may be associated with a gage height.
1 - | gage height affected by backwater
3 - | gage height at different site and/or datum
4 - | gage height below minimum recordable elevation
5 - | gage height is an estimate
6 - | gage datum changed during this year


Appendix C. Data-Set Attributes

Data-set attributes in a Watershed Data Management (WDM) file are used to describe the data sets. Attributes may describe how the data is stored in the data set, where the data was gathered, physical features of the associated data, and statistics computed from the associated data. Over 300 attributes are available for describing data sets. Only a fraction of these attributes are used by PeakFQ, but any attribute may be present in the data set.

Appendix C.1 contains a listing and description of the data-set attributes frequently found in annual peak-flow data sets. Appendix C.2 contains a listing of the attributes that PeakFQ reads and (or) writes or that are frequently associated with annual peak-flow data sets and how these attributes are used by the PeakFQ program. The IOWDM program is usually used to add most of these attributes to the data sets, but they can be manually entered using the ANNIE program. The basin characteristic and station header formats are described in Appendices B.2 and B.3. See the IOWDM and ANNIE documentation for additional details. Some of these attributes may be modified each time the PeakFQ program is run. Some of these attributes are output from PeakFQ. Some of these attributes are ignored by PeakFQ.


Appendix C.1. Definitions

 Table C.1. Attributes associated with annual peak-flow data sets

 |  |  |  | Data-set type
Name | Type | Length | Update | Time | Table | Description
AGENCY | Char | 8 | Yes | Opt | Opt | Agency code.
AQTYPE | Char | 4 | Yes | Opt | Opt | Aquifer type. U - unconfined single aquifer N - unconfined multiple aquifers C - confined single aquifer M - confined multiple aquifers X - mixed multiple aquifers
BASEQ | Real | 1 | Yes | Opt | Opt | Base discharge, in cubic feet per second.
COCODE | Int | 1 | Yes | Opt | Opt | County or parish code.
CONTDA | Real | 1 | Yes | Opt | Opt | Drainage area, in square miles, that contributes to surface runoff.
DAREA | Real | 1 | Yes | Opt | Opt | Total drainage area, in square miles, including noncontributing areas.
DATUM | Real | 1 | Yes | Opt | Opt | Reference elevation, to mean sea level.
DSCODE | Int | 1 | Yes | Opt | Opt | State code of the Geological Survey office that operates the station. Usually the same as the state code (STFIPS).
GUCODE | Char | 12 | Yes | Opt | Opt | Geologic unit code.
HUCODE | Int | 1 | Yes | Opt | Opt | Hydrologic unit code (8 digits). These codes are given in the U.S. Geological Survey map series "State Hydrologic Unit Maps," Open-File Report 84-708.
ISTAID | Int | 1 | Yes | Opt | Opt | Station identification number, as an integer.
J407BQ | Real | 1 | Yes | Opt | Opt | Base gage discharge.
J407BY | Int | 1 | Yes | Opt | Opt | Year to begin analysis, used to identify subset of available record.
J407EY | Int | 1 | Yes | Opt | Opt | Year to end analysis, used to identify subset of available record.
J407GS | Real | 1 | Yes | Opt | Opt | Generalized skew.
J407HO | Real | 1 | Yes | Opt | Opt | High outlier discharge criterion.
J407LO | Real | 1 | Yes | Opt | Opt | Low outlier discharge criterion.
J407NH | Int | 1 | Yes | Opt | Opt | Number of historic peaks.
J407SE | Real | 1 | Yes | Opt | Opt | Root mean square error of generalized skew.
J407SO | Int | 1 | Yes | Opt | Opt | Generalized skew option. -1 - station skew 0 - weighted skew 1 - generalized skew
J407UR | Int | 1 | Yes | Opt | Opt | Include urban regulated peaks. 1 - no 2 - yes
LATDEG | Real | 1 | Yes | Opt | Opt | Latitude in decimal degrees.
LATDMS | Int | 1 | Yes | Opt | Opt | Latitude in degrees, minutes, seconds (dddmmss).
LNGDEG | Real | 1 | Yes | Opt | Opt | Longitude in decimal degrees.
LNGDMS | Int | 1 | Yes | Opt | Opt | Longitude in degrees, minutes, seconds (dddmmss).
P1.25 | Real | 1 | Yes | Opt | Opt | Annual flood peak, in cubic feet per second, 1.25-year recurrence interval.
P10. | Real | 1 | Yes | Opt | Opt | Annual flood peak, in cubic feet per second, 10-year recurrence interval.
P100. | Real | 1 | Yes | Opt | Opt | Annual flood peak, in cubic feet per second, 100-year recurrence interval.
P2. | Real | 1 | Yes | Opt | Opt | Annual flood peak, in cubic feet per second, 2-year recurrence interval.
P200. | Real | 1 | Yes | Opt | Opt | Annual flood peak, in cubic feet per second, 200-year recurrence interval.
P25. | Real | 1 | Yes | Opt | Opt | Annual flood peak, in cubic feet per second, 25-year recurrence interval.
P5. | Real | 1 | Yes | Opt | Opt | Annual flood peak, in cubic feet per second, 5-year recurrence interval.
P50. | Real | 1 | Yes | Opt | Opt | Annual flood peak, in cubic feet per second, 50-year recurrence interval.
P500. | Real | 1 | Yes | Opt | Opt | Annual flood peak, in cubic feet per second, 500-year recurrence interval.
SITECO | Char | 4 | Yes | Opt | Opt | Site code. SW - stream SP - spring ES - estuary GW - well LK - lake or reservoir ME - meteorological
STAID | Char | 16 | Yes | Opt | Opt | Station identification, up to 16 alpha-numeric characters.
STANAM | Char | 48 | Yes | Opt | Opt | Station name or description of the data set.
STFIPS | Int | 1 | Yes | Opt | Opt | State FIPS code.
TSTYPE | Char | 4 | Yes | Opt | Opt | User-defined four-character descriptor. Used to describe the contents of the data set, for example: PRCP, RAIN, SNOW - precipitation FLOW, DISC, PEAK - discharge TEMP, TMIN, TMAX - temperature EVAP, PET - evapotranspiration Some models and application programs may require a specific TSTYPE for data sets they use.
WELLDP | Real | 1 | Yes | Opt | Opt | Depth of well, in feet. The greatest depth at which water can enter the well.
WRCMN | Real | 1 | Yes | Opt | Opt | Mean of logarithms, base 10, of annual peak discharges after outlier and historic-peak adjustments.
WRCSD | Real | 1 | Yes | Opt | Opt | Standard deviation of logarithms, base 10, of annual peak discharges after outlier and historic-peak adjustments.
WRCSKW | Real | 1 | Yes | Opt | Opt | Skew of logarithms, base 10, of annual peak discharge after outlier and historic-peak adjustments and generalized skew weighting.
YRSHPK | Int | 1 | Yes | Opt | Opt | Number of consecutive years used for historic-peak adjustment to flood-frequency data.


Appendix C.2. Sources

 Table C.2. Sources of attributes associated with peak-flow data sets

WDM file        as processed by IOWDM      PeakFQ
---------    ---------------------------    use *    * i - input by user
attribute    basin charac   statn header   -------     r - read from WDM
 name  no.     name   no.   name     rec   i r w p     w - written to WDM
----------   ------------   ------------   -------     p - written to "punch"
istaid  51   sta id    --   sta id     N     x
staid    2   sta id    --   sta id     N   x x
stanam  45   sta name  --   sta name   N   x x
latdms  54                                   x
lngdms  55                                   x
latdeg   8   lat gage  22   latitude   H   x x
lngdeg   9   lng gage  23   longitude  H   x x
yrshpk  81   yrshispk 197                    x x
j407by 278                                   x x
j407ey 279                                   x x
j407lo 269                                   x x
j407ho 270                                   x x
j407so 271                                   x x
j407gs 272                                   x x
j407bq 273                                   x x
j407se 275                                   x x
j407ur 276                                   x x
j407nh 274                                   x x
wrcmn   78   wrc mn   180                      x x
wrcsd   79   wrc sd   181                      x x
wrcskw  77   wrc skew 179                      x x
p1.25   65   p1,25     75                      x x
p2.     66   p2        76                      x x
p5.     67   p5        77                      x x
p10.    68   p10       78                      x x
p25.    69   p25       79                      x x
p50.    70   p50       80                      x x
p100.   71   p100      81                      x x
p200.   72   p200      82                      x x
p500.   73   p500     178                      x x

meanpk  74   meanpk    83                        x
sdpk    75   sdpk      84                        x
skewpk  76   skewpk    85                        x
tmtopk  98   timetopk  21
yrspk   80   yrspk    196                        x
darea   11   area       1   area       H
contda  43   contda     2   cont area  H
agency  40                  agency     Z
stfips  41   state c   --   state code H
dscode  42   dist c    --   dist code  H
siteco  44                  site code  H
hucode   4                  hyd unit c H
datum  264                  datum      H
welldp  47                  well dpth  H
gucode  46                  geol unit  N
aqtype  48                  aquifer tp N
baseq   49                  base q     Y


Appendix D. Sample Files

Appendix D contains a suite of sample files, both input and output, for a PeakFQ run.

Appendix D.1 shows a specification file for performing an analysis of the sample input file.
Appendix D.2 shows an input file containing data for a single station.
Appendix D.3 shows the resulting output file from the PeakFQ run using the sample input and specification file. It also shows a graphical plot of the results.


Appendix D.1. Sample Specification File

 Appendix D.1. Sample Input File
I ASCI BigSandy.inp
O File BigSandy.out
O Plot Style Graphics
O Plot Format WMF
Station 03606500
     HistPeriod 77
     SkewOpt Weighted
     GenSkew -0.2
     PlotName 03606500


Appendix D.3. Sample Output File

 Table D.3. Sample Output File
1
  Program PeakFq           U. S. GEOLOGICAL SURVEY             Seq.000.000
  Ver. 5.0 Beta 8     Annual peak flow frequency analysis      Run Date / Time
  05/06/2005          following Bulletin 17-B Guidelines       07/20/2005 15:02

                         --- PROCESSING OPTIONS ---

                      Plot option         = Graphics device
                      Basin char output   = None
                      Print option        = Yes
                      Debug print         = No
                      Input peaks listing = Long
                      Input peaks format  = WATSTORE peak file

                      Input files used:
                         peaks (ascii)  - D:\EX\BIGSANDY.INP
                         specifications - PKFQWPSF.TMP
                      Output file(s):
                         main - D:\EX\BIGSANDY.OUT

1

  Program PeakFq           U. S. GEOLOGICAL SURVEY             Seq.001.001
  Ver. 5.0 Beta 8     Annual peak flow frequency analysis      Run Date / Time
  05/06/2005          following Bulletin 17-B Guidelines       07/20/2005 15:02

          Station - 03606500  BIG SANDY RIVER AT BRUCETON HIST B-17-B

                     I N P U T   D A T A   S U M M A R Y

                Number of peaks in record            =       47
                Peaks not used in analysis           =        0
                Systematic peaks in analysis         =       44
                Historic peaks in analysis           =        3
                Years of historic record             =       77
                Generalized skew                     =   -0.200
                     Standard error                  =    0.550
                     Mean Square error               =    0.303
                Skew option                          =   WEIGHTED
                Gage base discharge                  =      0.0
                User supplied high outlier threshold =   --
                User supplied low outlier criterion  =   --
                Plotting position parameter          =     0.00

  *********  NOTICE  --  Preliminary machine computations.        *********
  *********  User responsible for assessment and interpretation.  *********

    WCF134I-NO SYSTEMATIC PEAKS WERE BELOW GAGE BASE.                   0.0
    WCF195I-NO LOW OUTLIERS WERE DETECTED BELOW CRITERION.            921.3
    WCF156I-17B HI-OUTLIER TEST SUPERSEDED BY MIN HIST PK   26151.7
    WCF165I-HIGH OUTLIERS AND HISTORIC PEAKS ABOVE HHBASE.  0  3    18500.0
1

  Program PeakFq           U. S. GEOLOGICAL SURVEY             Seq.001.002
  Ver. 5.0 Beta 8     Annual peak flow frequency analysis      Run Date / Time
  05/06/2005          following Bulletin 17-B Guidelines       07/20/2005 15:02

          Station - 03606500  BIG SANDY RIVER AT BRUCETON HIST B-17-B

           ANNUAL FREQUENCY CURVE PARAMETERS -- LOG-PEARSON TYPE III

                        FLOOD BASE                   LOGARITHMIC
                  ----------------------  -------------------------------
                             EXCEEDANCE                STANDARD
                   DISCHARGE PROBABILITY     MEAN     DEVIATION     SKEW
                  -------------------------------------------------------
 SYSTEMATIC RECORD       0.0     1.0000     3.6909      0.2672     -0.187
 BULL.17B ESTIMATE       0.0     1.0000     3.7158      0.2890     -0.004

    ANNUAL FREQUENCY CURVE -- DISCHARGES AT SELECTED EXCEEDANCE PROBABILITIES

      ANNUAL                              'EXPECTED   95-PCT CONFIDENCE LIMITS
   EXCEEDANCE     BULL.17B    SYSTEMATIC PROBABILITY'  FOR BULL. 17B ESTIMATES
   PROBABILITY    ESTIMATE      RECORD     ESTIMATE        LOWER        UPPER

      0.9950        934.4        903.1        845.2        618.9       1262.0
      0.9900       1104.0       1078.0       1020.0        754.8       1459.0
      0.9500       1739.0       1728.0       1676.0       1292.0       2180.0
      0.9000       2216.0       2206.0       2165.0       1714.0       2710.0
      0.8000       2970.0       2943.0       2935.0       2396.0       3550.0
      0.6667       3905.0       3827.0       3886.0       3246.0       4612.0
      0.5000       5202.0       5004.0       5202.0       4399.0       6152.0
      0.4292       5858.0       5580.0       5868.0       4965.0       6964.0
      0.2000       9104.0       8278.0       9213.0       7616.0      11290.0
      0.1000      12200.0      10660.0      12480.0       9970.0      15770.0
      0.0400      16650.0      13840.0      17360.0      13190.0      22690.0
      0.0200      20360.0      16310.0      21600.0      15750.0      28770.0
      0.0100      24400.0      18860.0      26380.0      18460.0      35660.0
      0.0050      28790.0      21490.0      31800.0      21330.0      43430.0
      0.0020      35180.0      25090.0      40120.0      25390.0      55200.0
1

  Program PeakFq           U. S. GEOLOGICAL SURVEY             Seq.001.003
  Ver. 5.0 Beta 8     Annual peak flow frequency analysis      Run Date / Time
  05/06/2005          following Bulletin 17-B Guidelines       07/20/2005 15:02

          Station - 03606500  BIG SANDY RIVER AT BRUCETON HIST B-17-B

                       I N P U T   D A T A   L I S T I N G

     WATER YEAR    DISCHARGE   CODES      WATER YEAR    DISCHARGE   CODES

       -1897        25000.0        H         1951         5230.0
       -1919        21000.0        H         1952         4260.0
       -1927        18500.0        H         1953         5000.0
        1930         9100.0                  1954         3320.0
        1931         2060.0                  1955         5480.0
        1932         7820.0                  1956        11800.0
        1933         3220.0                  1957         5150.0
        1934         5580.0                  1958         3350.0
        1935        17000.0                  1959         2400.0
        1936         6740.0                  1960         1460.0
        1937        13800.0                  1961         3770.0
        1938         4270.0                  1962         7480.0
        1939         5940.0                  1963         2740.0
        1940         1680.0                  1964         3100.0
        1941         1200.0                  1965         7180.0
        1942        10100.0                  1966         1920.0
        1943         3780.0                  1967         9060.0
        1944         5340.0                  1968         3080.0
        1945         5630.0                  1969         2800.0
        1946        12000.0                  1970         4330.0
        1947         3980.0                  1971         5080.0
        1948         6130.0                  1972        12000.0
        1949         4740.0                  1973         7640.0
        1950         9880.0

        Explanation of peak discharge qualification codes

       PEAKFQ    NWIS
        CODE     CODE   DEFINITION

          D        3    Dam failure, non-recurrent flow anomaly
          G        8    Discharge greater than stated value
          X       3+8   Both of the above
          L        4    Discharge less than stated value
          K     6 OR C  Known effect of regulation or urbanization
          H        7    Historic peak

          -  Minus-flagged discharge -- Not used in computation
                -8888.0 -- No discharge value given
          -  Minus-flagged water year -- Historic peak used in computation

1

  Program PeakFq           U. S. GEOLOGICAL SURVEY             Seq.001.004
  Ver. 5.0 Beta 8     Annual peak flow frequency analysis      Run Date / Time
  05/06/2005          following Bulletin 17-B Guidelines       07/20/2005 15:02

          Station - 03606500  BIG SANDY RIVER AT BRUCETON HIST B-17-B

   EMPIRICAL FREQUENCY CURVES -- WEIBULL PLOTTING POSITIONS

      WATER         RANKED       SYSTEMATIC      BULL.17B
       YEAR       DISCHARGE        RECORD        ESTIMATE

      -1897        25000.0           --           0.0128
      -1919        21000.0           --           0.0256
      -1927        18500.0           --           0.0385
       1935        17000.0         0.0222         0.0557
       1937        13800.0         0.0444         0.0772
       1946        12000.0         0.0667         0.0988
       1972        12000.0         0.0889         0.1203
       1956        11800.0         0.1111         0.1419
       1942        10100.0         0.1333         0.1635
       1950         9880.0         0.1556         0.1850
       1930         9100.0         0.1778         0.2066
       1967         9060.0         0.2000         0.2281
       1932         7820.0         0.2222         0.2497

       1973         7640.0         0.2444         0.2713
       1962         7480.0         0.2667         0.2928
       1965         7180.0         0.2889         0.3144
       1936         6740.0         0.3111         0.3360
       1948         6130.0         0.3333         0.3575
       1939         5940.0         0.3556         0.3791
       1945         5630.0         0.3778         0.4006
       1934         5580.0         0.4000         0.4222
       1955         5480.0         0.4222         0.4438
       1944         5340.0         0.4444         0.4653
       1951         5230.0         0.4667         0.4869
       1957         5150.0         0.4889         0.5084
       1971         5080.0         0.5111         0.5300
       1953         5000.0         0.5333         0.5516
       1949         4740.0         0.5556         0.5731
       1970         4330.0         0.5778         0.5947
       1938         4270.0         0.6000         0.6163
       1952         4260.0         0.6222         0.6378
       1947         3980.0         0.6444         0.6594
       1943         3780.0         0.6667         0.6809
       1961         3770.0         0.6889         0.7025
       1958         3350.0         0.7111         0.7241
       1954         3320.0         0.7333         0.7456
       1933         3220.0         0.7556         0.7672
       1964         3100.0         0.7778         0.7888
       1968         3080.0         0.8000         0.8103
       1969         2800.0         0.8222         0.8319
       1963         2740.0         0.8444         0.8534
       1959         2400.0         0.8667         0.8750
       1931         2060.0         0.8889         0.8966
       1966         1920.0         0.9111         0.9181
       1940         1680.0         0.9333         0.9397
       1960         1460.0         0.9556         0.9612
       1941         1200.0         0.9778         0.9828
1

 End PEAKFQ analysis.
   Stations processed :       1
   Number of errors   :       0
   Stations skipped   :       0
   Station years      :      47

Data records may have been ignored for the stations listed below.
(Card type must be Y, Z, N, H, I, 2, 3, 4,  or *.)
(2, 4, and * records are ignored.)

 For the station below, the following records were ignored:
2 03606500

 FINISHED PROCESSING STATION:  03606500       USGS BIG SANDY RIVER AT BRUCETON H

 For the station below, the following records were ignored:

 FINISHED PROCESSING STATION:
Sample Graphic Output


Appendix B.4. Peak-Flows Records

The peak-flows records may be preceded by station header records.

  • Calendar year if columns 21-22 contain a valid month
  • Water year if columns 21-22 are blank or 99
This entry may or may not be the same as on the preceding type 3 record if one is present, but the month and year must have occurred in water year as the peak discharge.
recordcolumnformatWDM
attribute		description
31"3"--Record identifier.
2-16 | A15 | STAID or ISTAID | Station identification number.
17-20I4--Year peak occurred:
  • Calendar year if columns 21-22 contain a valid month
  • Water year if columns 21-22 are blank or 99
21-22I2--Month the annual peak discharge occurred. Blank if month is not known.
23-24I2--Day of the month the annual peak discharge occurred. Blank if day is not known.
25-31F7.0--Annual peak discharge, right justified.
32-43A12--Annual peak discharge qualification codes. More than one code may be associated with a peak, except as noted below.
1 - | discharge is a maximum daily average
2 - | discharge is an estimate
3 - | discharge affected by dam failure
4 - | discharge less than indicated value, which is minimum recordable discharge at this site *
5 - | discharge affected to unknown degree by regulation or diversion **
6 - | discharge affected by regulation or diversion **
7 - | discharge is a historic peak ***
8 - | discharge actually greater than indicated value
9 - | discharge due to snowmelt, hurricane, ice-jam or debris dam breakup
A - | year of occurrence is unknown or not exact
B - | month or day of occurrence is unknown or not exact
C - | all or part of the record affected by urbanization, mining, agricultural changes, channelization, or others
D - | base discharge changed during this year
E - | only annual maximum peak available for this year
* | Code 4 cannot occur simultaneously with codes 1, 2, 3, 7, or 8.
** | Codes 5 and 6 cannot occur simultaneously
*** | Code 7 should indicate that the value for the particular year is a historic peak and the particular year occurred before or after the systematic record, or during a break in the systematic record.
44-51F8.0--Gage height associated with annual peak discharge, right justified in field.
52-55A4Gage height qualification codes. More than one code may be associated with a gage height.
1 - | gage height affected by backwater
2 - | gage height not the maximum for the year
3 - | gage height at different site and/or datum
4 - | gage height below minimum recordable elevation
5 - | gage height is an estimate
6 - | gage datum changed during this year
* | If code 2 is given here, then a date and data entries should be made for the maximum annual gage height (cols 60-75).
56-59 | I4 | "Highest since" year -- representing the calendar year after which the given peak discharge (cols 25-31) is known to be the highest. This year is determined from historic newspaper accounts, local information, or other sources.
60-61I2--Month in which the annual peak gage height occurred. While this month may not be in the same calendar year as the annual peak, it is that it is in the same water year.
62-63I2--Day of the month of the annual peak gage height.
64-71 | F8.0 | Annual peak gage height.
72-75A4--Annual peak gage height qualification codes
1 - | gage height affected by backwater
3 - | gage height at different site and/or datum
5 - | gage height is an estimate
6 - | gage datum changed during this year
41"4"--Record identifier.
2-16 | A15 | STAID or ISTAID | Station identification number.
17-20I4--Year data on this record occurred
21-22I2--Month the partial duration peak occurred. Blank if month is not known.
23-24I2--Day of the month the partial duration peak occurred. Blank if day is not known.
25-31F7.0--Partial duration peak discharge, right justified.
32-43A12--Partial duration peak discharge qualification codes. More than one code may be associated with a peak.
1 - | discharge is a maximum daily average
2 - | discharge is an estimate
3 - | discharge affected by dam failure
4 - | discharge less than indicated value, which is minimum recordable discharge at this site *
5 - | discharge affected to unknown degree by regulation or diversion **
6 - | discharge affected by regulation or diversion **
7 - | discharge is an historic peak ***
8 - | discharge actually grater than indicated value
9 - | discharge due to snowmelt, hurricane, ice-jam or debris dam breakup
A - | year of occurrence is unknown or not exact
B - | month or day of occurrence is unknown or not exact
C - | all or part of the record affected by urbanization, mining, agricultural changes, channelization, or others
D - | base discharge changed during this year
E - | only annual maximum peak available for this year
* | Code 4 cannot occur simultaneously with codes 1, 2, 3, 7, or 8.
** | Codes 5 and 6 cannot occur simultaneously.
*** | Code 7 should indicate that the value for the particular year is a historic peak and the particular year occurred before or after the systematic record, or during a break in the systematic record.
44-51 | F8.0 | Partial duration peak gage height.
52-55A4Partial duration peak gage height qualification codes. More than one code may be associated with a gage height.
1 - | gage height affected by backwater
3 - | gage height at different site and/or datum
4 - | gate height below minimum recordable elevation
5 - | gage height is an estimate
6 - | gage datum changed during this year


Appendix D.2. Specification

 Appendix D.2. Sample Specification File
I ASCI TEST1.INP
O File TEST1.OUT
O Plot Style Graphics
0 Plot Format CGM
Station 11274500
     BegYear 1932
     EndYear 1973
     SkewOpt Generalized
     GenSkew 0.2


Appendix D.3. Output

 Table D.3. Sample Output File
1
  Program PeakFq           U. S. GEOLOGICAL SURVEY             Seq.000.000
  Ver. 5.0 Beta 8     Annual peak flow frequency analysis      Run Date / Time
  05/06/2005          following Bulletin 17-B Guidelines       05/06/2005 14:23

                         --- PROCESSING OPTIONS ---

                      Plot option         = Graphics device
                      Basin char output   = None
                      Print option        = Yes
                      Debug print         = No
                      Input peaks listing = Long
                      Input peaks format  = WATSTORE peak file

                      Input files used:
                         peaks (ascii)  - TEST1.INP
                         specifications - test1.psf
                      Output file(s):
                         main - TEST1.OUT

1

  Program PeakFq           U. S. GEOLOGICAL SURVEY             Seq.001.001
  Ver. 5.0 Beta 8     Annual peak flow frequency analysis      Run Date / Time
  05/06/2005          following Bulletin 17-B Guidelines       05/06/2005 14:23

             Station - 11274500  Orestimba Creek near Newman Calif

                     I N P U T   D A T A   S U M M A R Y

                Number of peaks in record            =       42
                Peaks not used in analysis           =        0
                Systematic peaks in analysis         =       42
                Historic peaks in analysis           =        0
                Years of historic record             =        0
                Generalized skew                     =    0.200
                     Standard error                  =    0.550
                     Mean Square error               =    0.303
                Skew option                          =  GENERALIZED
                Gage base discharge                  =      0.0
                User supplied high outlier threshold =   --
                User supplied low outlier criterion  =   --
                Plotting position parameter          =     0.00

  *********  NOTICE  --  Preliminary machine computations.        *********
  *********  User responsible for assessment and interpretation.  *********

    WCF133I-SYSTEMATIC PEAKS BELOW GAGE BASE WERE NOTED.         6      0.0
    WCF198I-LOW OUTLIERS BELOW FLOOD BASE WERE DROPPED.       1        23.9
    WCF163I-NO HIGH OUTLIERS OR HISTORIC PEAKS EXCEEDED HHBASE.     41785.9
   *WCF151I-17B WEIGHTED SKEW REPLACED BY USER OPTION.    -0.312     0.200   1
1

  Program PeakFq           U. S. GEOLOGICAL SURVEY             Seq.001.002
  Ver. 5.0 Beta 8     Annual peak flow frequency analysis      Run Date / Time
  05/06/2005          following Bulletin 17-B Guidelines       05/06/2005 14:23

             Station - 11274500  Orestimba Creek near Newman Calif

           ANNUAL FREQUENCY CURVE PARAMETERS -- LOG-PEARSON TYPE III

                        FLOOD BASE                   LOGARITHMIC
                  ----------------------  -------------------------------
                             EXCEEDANCE                STANDARD
                   DISCHARGE PROBABILITY     MEAN     DEVIATION     SKEW
                  -------------------------------------------------------
 SYSTEMATIC RECORD       0.0     0.8571     2.9115      0.7721     -0.954
 BULL.17B ESTIMATE      23.9     0.8333     2.9614      0.6781      0.200

    ANNUAL FREQUENCY CURVE -- DISCHARGES AT SELECTED EXCEEDANCE PROBABILITIES

      ANNUAL                              'EXPECTED   95-PCT CONFIDENCE LIMITS
   EXCEEDANCE     BULL.17B    SYSTEMATIC PROBABILITY'  FOR BULL. 17B ESTIMATES
   PROBABILITY    ESTIMATE      RECORD     ESTIMATE        LOWER        UPPER

      0.8000        242.7        210.1        236.1        144.4        372.6
      0.6667        448.1        491.7        442.9        286.0        668.8
      0.5000        868.5       1078.0        868.5        579.3       1298.0
      0.4292       1149.0       1446.0       1154.0        771.9       1736.0
      0.2000       3345.0       3716.0       3450.0       2183.0       5600.0
      0.1000       6975.0       6154.0       7422.0       4291.0      13020.0
      0.0400      15620.0       9568.0      17540.0       8822.0      33580.0
      0.0200      26640.0      12120.0      31440.0      14110.0      63320.0
      0.0100      43420.0      14560.0      54330.0      21610.0     113600.0
      0.0050      68390.0      16840.0      91470.0      32050.0     195900.0
      0.0020     119700.0      19560.0     177000.0      51970.0     384400.0
1

  Program PeakFq           U. S. GEOLOGICAL SURVEY             Seq.001.003
  Ver. 5.0 Beta 8     Annual peak flow frequency analysis      Run Date / Time
  05/06/2005          following Bulletin 17-B Guidelines       05/06/2005 14:23

             Station - 11274500  Orestimba Creek near Newman Calif

                       I N P U T   D A T A   L I S T I N G

     WATER YEAR    DISCHARGE   CODES      WATER YEAR    DISCHARGE   CODES

        1932         4260.0                  1953          147.0
        1933          345.0                  1954            0.0
        1934          516.0                  1955           16.0
        1935         1320.0                  1956         5620.0
        1936         1200.0                  1957         1440.0
        1937         2180.0                  1958        10200.0
        1938         3230.0                  1959         5380.0
        1939          115.0                  1960          448.0
        1940         3440.0                  1961            0.0
        1941         3070.0                  1962         1740.0
        1942         1880.0                  1963         8300.0
        1943         6450.0                  1964          156.0
        1944         1290.0                  1965          560.0
        1945         5970.0                  1966          128.0
        1946          782.0                  1967         4200.0
        1947            0.0                  1968            0.0
        1948            0.0                  1969         5080.0
        1949          335.0                  1970         1010.0
        1950          175.0                  1971          584.0
        1951         2920.0                  1972            0.0
        1952         3660.0                  1973         1510.0

        Explanation of peak discharge qualification codes

       PEAKFQ    NWIS
        CODE     CODE   DEFINITION

          D        3    Dam failure, non-recurrent flow anomaly
          G        8    Discharge greater than stated value
          X       3+8   Both of the above
          L        4    Discharge less than stated value
          K     6 OR C  Known effect of regulation or urbanization
          H        7    Historic peak

          -  Minus-flagged discharge -- Not used in computation
                -8888.0 -- No discharge value given
          -  Minus-flagged water year -- Historic peak used in computation

1

  Program PeakFq           U. S. GEOLOGICAL SURVEY             Seq.001.004
  Ver. 5.0 Beta 8     Annual peak flow frequency analysis      Run Date / Time
  05/06/2005          following Bulletin 17-B Guidelines       05/06/2005 14:23

             Station - 11274500  Orestimba Creek near Newman Calif

   EMPIRICAL FREQUENCY CURVES -- WEIBULL PLOTTING POSITIONS

      WATER         RANKED       SYSTEMATIC      BULL.17B
       YEAR       DISCHARGE        RECORD        ESTIMATE

       1958        10200.0         0.0233         0.0233
       1963         8300.0         0.0465         0.0465
       1943         6450.0         0.0698         0.0698
       1945         5970.0         0.0930         0.0930
       1956         5620.0         0.1163         0.1163
       1959         5380.0         0.1395         0.1395
       1969         5080.0         0.1628         0.1628
       1932         4260.0         0.1860         0.1860
       1967         4200.0         0.2093         0.2093
       1952         3660.0         0.2326         0.2326
       1940         3440.0         0.2558         0.2558
       1938         3230.0         0.2791         0.2791
       1941         3070.0         0.3023         0.3023
       1951         2920.0         0.3256         0.3256
       1937         2180.0         0.3488         0.3488
       1942         1880.0         0.3721         0.3721
       1962         1740.0         0.3953         0.3953
       1973         1510.0         0.4186         0.4186
       1957         1440.0         0.4419         0.4419
       1935         1320.0         0.4651         0.4651
       1944         1290.0         0.4884         0.4884
       1936         1200.0         0.5116         0.5116
       1970         1010.0         0.5349         0.5349
       1946          782.0         0.5581         0.5581
       1971          584.0         0.5814         0.5814
       1965          560.0         0.6047         0.6047
       1934          516.0         0.6279         0.6279
       1960          448.0         0.6512         0.6512
       1933          345.0         0.6744         0.6744
       1949          335.0         0.6977         0.6977
       1950          175.0         0.7209         0.7209
       1964          156.0         0.7442         0.7442
       1953          147.0         0.7674         0.7674
       1966          128.0         0.7907         0.7907
       1939          115.0         0.8140         0.8140
       1955           16.0         0.8372         0.8372
       1947            0.0           --             --
       1948            0.0           --             --
       1954            0.0           --             --
       1961            0.0           --             --
       1968            0.0           --             --
       1972            0.0           --             --
1

 End PEAKFQ analysis.
   Stations processed :       1
   Number of errors   :       0
   Stations skipped   :       3
   Station years      :      42

Data records may have been ignored for the stations listed below.
(Card type must be Y, Z, N, H, I, 2, 3, 4,  or *.)
(2, 4, and * records are ignored.)

 For the station below, the following records were ignored:

 FINISHED PROCESSING STATION:  01373500            Fishkill Cr at Beacon NY

 For the station below, the following records were ignored:

 FINISHED PROCESSING STATION:  06600500            Floyd River at James, Iowa

 For the station below, the following records were ignored:

 FINISHED PROCESSING STATION:  01614000            Back Creek near Jones Springs

 For the station below, the following records were ignored:

 FINISHED PROCESSING STATION:  11274500            Orestimba Creek near Newman C

 For the station below, the following records were ignored:

 FINISHED PROCESSING STATION:
Sample Graphic Output